Katalon does not see the connected iphone 4s

I did everything according to the instructions: https://docs.katalon.com/katalon-studio/docs/mobile-on-macos.html#katalon-studio-supported-environment-on-macos

Katalon does not see connected Iphone 4s. Only simulators. UI Automation enable.
Command instruments -s devices sees Iphone 4s, Xcode too.

macoS 10.14 mojave
nodejs v11.11.0
appium 1.8.1
ios-deploy 1.9.4
carthage 0.32.0

Xcode 9.4.1
Katalon 6.0.6
IPhone 4s (iOS 9.3.5)

Please, help!

Hi @a.kachalin,

This is a common problem but there isn’t one straightforward solution. Here is a post with a few things you can try:

Hope this helps,


Hi,Chris.I tried to follow the steps you provided, but when I tried to find the file ‘settings/internal/com.kms.katalon.core.mobile.ios.propertie’ under my test project, I found that there was no such file. What should I do?

Hi @leochen,

If you don’t have the settings/internal/com.kms.katalon.core.mobile.ios.properties file in your project already, don’t worry, you can create one. Just make sure you put it in the correct subdirectory under your project. You should be able to make the contents of the file as simple as:


Where 0C3F1694-ADB9-4010-AD3C-A0BE533746EE is the device id for the device you want to run the tests on.

Hope this helps,


Hi,Chris.Frist,thank you very much for your reply. I tried to create a new file according to your method and put it in the project directory correctly, but when I ran the script with katalon, I still made an error. See the screenshot below.


Hi @leochen,

Thanks for providing the info and screenshot. Can you confirm if you’ve tried the following steps to reset some of the tools:

brew uninstall ideviceinstaller
brew uninstall libimobiledevice
brew install --HEAD libimobiledevice
brew link --overwrite libimobiledevice
brew install --HEAD  ideviceinstaller
brew link --overwrite ideviceinstaller
sudo chmod -R 777 /var/db/lockdown/

If you have tried that and it still doesn’t work, could you see if you have an appium.log file in your test directory that you could share?



Hi,Chris.Thank you for your patient teaching.I have tried the above steps and it still doesn’t work.Here i will upload the appium.log and if it is not helpful, should i uninstall everything or try another machine?
appium.log (3.7 KB)

Hi @leochen,

Thanks for providing the log file. It looks like it’s for a test that was run with an Android device, so I’m guessing that the problem you see with the iOS device isn’t logged anywhere.

From what I have read from other people having the same issue with real iOS devices not showing, they sometimes have luck trying it on another computer. Unfortunately, I don’t have an explanation as to why that would fix it. You could also try uninstalling and reinstalling Katalon Studio, maybe trying the latest version, which is 6.1.4 at the time of this writing may help.

Please keep me posted as to what you try and if it works.

– Chris

Hi,Chris.I’ve tried the latest version of katalon 6.1.4, but unfortunately, it still doesn’t work well for katalon to recognize my iPhone device. Based on my past experience, I think it’s probably because I didn’t install the dependencies that allow Katalon to identify the iPhone devices correctly or because the versions of those dependencies are incorrect.So you can tell me what dependencies you installed and how many versions of those dependencies are, and I’ll try to install them to see if katalon can successfully identify my device. In addition, my current version of MacOS system is 10.13.6. The Xcode version is 10.1

RecoveryTool Fix Recovery may solve the problem.

issue duplicated