Katalon does not see iOS simulators on M1

Hello,

The ready iOS simulator is not visible in Katalon. I only have one simulator and no connected devices. I tried all the possible solutions out there in other forums, tutorials and any shred of documentation so please read the below carefully.

Everything seems to be set up properly:

  • Webdriver test is running correctly: when I run xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination 'id=<B68E8E50-70D3-4FAE-AC35-4CB510A924AF!' test, the test starts without issues and the integration app is installed
  • Simulator appears as booted in the list when I run xcrun simctl list: iPhone 8 (B68E8E50-70D3-4FAE-AC35-4CB510A924AF) (Booted)
  • xcode-select -p returns /Applications/Xcode.app/Contents/Developer

Iā€™m thinking that Katalon is having trouble connecting to the available and existing simulator for iOS.

Below are all the libraries, tools, etc that I have installed

  1. Mac information:
  • macbook M1 chip
  • Mac OS: BigSur 11.6.1
  • Xcode 12.0.1 and Xcode command line for 12.0.1
  1. Tools, libraries, etc
  • which brew -> /opt/homebrew/bin/brew
  • which carthage -> /usr/local/bin/carthage
  • node 16.13.1; which node -> /usr/local/bin/
  • npm 8.1.2; which npm -> /usr/local/bin/npm
  • appim 1.22.2; which appium -> /usr/local/bin/appium
  • Katalon 8.2.0 (linked to the appium directory correctly, also Android is working with Katalon)
  • I also have in .zshrc:
    export PATH=/opt/homebrew/bin:$PATH
    export PATH=/opt/homebrew/bin/idevice_id:$PATH

Last but not least, I uninstalled and reinstalled everything 2 times. Please help! T_T

FIXED: After deleting all iOS simulators with iOS 14 and downloading iOS 13 simulators then Katalon was able to see my iOS 13 simulators.

1 Like