Katalon Console Execution Issues

When i run my suite in console mode, i see quite a lot of ‘Unable to find Element’,‘Object Not found’ failures whereas when i run the same in GUI it works. Has anyone faced similar issues ? Is there any solution ? I tried increasing wait times between actions,between test cases. I even tried cleaning up driver in between test cases. Nothing seemed to work. Any help appreciated.

maximize your screen? I’ve not done console mode but if you try headless and get the same results it might be related. I believe there is a way in console mode to set your screen size.

All my test cases have maximize screen in the Setup.i do not think screen size could be an issue. I do run in headless chrome in console mode though.

I confirmed again today when I ran my suite with Headless chrome in GUI, there was only expected failures. However in console mode, failure rate is high.

Hi @abirami

Which version of Katalon Studio are you using ? Can you provide us with a sample test project ( removing confidential information of sorts ) to reproduce this problem ?

Cheers !