Katalon Analytics uploads a blank report

I just set up Katalon Analytics to auto upload the results. After running the report a few times each one has uploaded a blank report with no duration, no tests, ect and just shows as passed for the result. Any suggestions how to fix this issue?

1 Like


This issue has been fixed, so please double check again by re-uploading your test executions :slight_smile:

@Zarashima I’m also facing this issue. Here’s the log. The first upload failed and the second one worked.

Fri Mar 29 10:30:01 CET 2019
Error when uploading log to Katalon Analytics Server
	at sun.nio.ch.FileChannelImpl.ensureOpen(FileChannelImpl.java:110)
	at sun.nio.ch.FileChannelImpl.write(FileChannelImpl.java:199)
	at java.nio.channels.Channels.writeFullyImpl(Channels.java:78)
	at java.nio.channels.Channels.writeFully(Channels.java:101)
	at java.nio.channels.Channels.access$000(Channels.java:61)
	at java.nio.channels.Channels$1.write(Channels.java:174)
	at java.io.OutputStream.write(OutputStream.java:75)
	at java.nio.channels.Channels$1.write(Channels.java:155)
	at java.util.zip.ZipOutputStream.writeInt(ZipOutputStream.java:720)
	at java.util.zip.ZipOutputStream.writeEND(ZipOutputStream.java:630)
	at java.util.zip.ZipOutputStream.finish(ZipOutputStream.java:366)
	at java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:238)
	at java.util.zip.ZipOutputStream.close(ZipOutputStream.java:377)
	at com.kms.katalon.core.util.internal.ZipUtil.compress(ZipUtil.java:94)
	at com.kms.katalon.integration.analytics.report.AnalyticsReportService.scanHarFiles(AnalyticsReportService.java:120)
	at com.kms.katalon.integration.analytics.report.AnalyticsReportService.scanFiles(AnalyticsReportService.java:109)
	at com.kms.katalon.integration.analytics.report.AnalyticsReportService.perform(AnalyticsReportService.java:80)
	at com.kms.katalon.integration.analytics.report.AnalyticsReportService.upload(AnalyticsReportService.java:55)
	at com.kms.katalon.integration.analytics.report.AnalyticsReportIntegration.uploadTestSuiteResult(AnalyticsReportIntegration.java:45)
	at com.kms.katalon.execution.launcher.ReportableLauncher.uploadReportToIntegratingProduct(ReportableLauncher.java:281)
	at com.kms.katalon.execution.launcher.ReportableLauncher.preExecutionComplete(ReportableLauncher.java:87)
	at com.kms.katalon.execution.launcher.ProcessLauncher.onWatchdogComplete(ProcessLauncher.java:191)
	at com.kms.katalon.execution.launcher.LaunchWatchdog.notifyProcessTerminated(LaunchWatchdog.java:135)
	at com.kms.katalon.execution.launcher.LaunchWatchdog.run(LaunchWatchdog.java:65)
	at java.lang.Thread.run(Thread.java:748)

@rj1 What’s your Katalon Studio version?

I’m using version 6.0.5

It only happens when the test suite “passed”. When it fails the upload works perfectly.

Hi @rj1,

Can you please try with the latest Katalon Studio version, it’s 6.1.0?

Hi! I didn’t see there was a new version available. Usually Katalon informs me about it. I updated and ran a test suite and it seems to be working. I’ll keep an eye on it.

1 Like

Getting this issue as well, was working fine yesterday however when I executed my test suites this morning, I’m seeing the attached. Any idea why this might be happening?


I am also seeing this issue.

While the suite is running, Analytics will show the suite testing is in progress and will have pass/fail results for the different test cases. As soon as the suite finishes running the results disappears and just says passed.

I ran the suite from the command line. I am running a test suite collection. I am on version 6.1.0. This used to work (about a week ago) but now doesn’t.

I tried opening the .rs file that’s in the reports folder but it just shows everything as status “Not Started”

According to this post it looks like they have identified an issue and are working on fixing it Katalon report uploader creates empty test suite executions?

1 Like

Hi @rj1 and @Gavin_Bannister,
Thank you for reporting the issue. There is a latency in populating test data onto your KA reports as we now have a larger volume of test logs. We’re now working on a solution for enhance the speed of parsing data for KA.


Any updates here? Yesterday every uploaded report was empty :frowning_face:

1 Like

Pending reports will be imported in a few hours. After that new reports will be imported quickly.

1 Like