Katalon 7 RC2 and v6.3.3


I am using Katalon Studio Version: 6.3.3 Build: 11 (with 2 plugins: Basic Report and Slack).

My scripts were running fine with no errors.

Then I tried Katalon 7 RC2. My scripts were running fine here as well.

I switched back to my Katalon 6.3.3 while waiting for the full release of Katalon 7.

Now when I try to run my scripts at the very beginning I get the following:


If I click the Proceed button the test does run and pass.

This is the only thing in the error log:

Launcher status after execution process completed: Running

Has anyone else tried Katalon 7 and then gone back to a 6.x version and seen this same issue?

Are scripts opened or created in Katalon 7 backwards compatible with Katalon 6.x?


cleanup your projects of the runtime builds allways before to switch to a new version.

Hi @Ibus, what do you mean by cleanup the project of the runtime builds? How do I do that?


search the forum please.
i don’t remember all of them, but you have to delete the folders like ‘build, lib’ and some .dotfiles.
start a new empty project, note the folder structure in file explorer.
make a simple testcase (it can be empty), run it > inspect the project folder again. you will notice some new folders and dotfiles are created.
those are the runtime files

Delete the highlighted items:


That worked. Thanks @Ibus and @Russ_Thomas!


on the other side, if i remember it right, katalon have somewere a ‘clean up’ option in the menu.
last time i tried was in the 5.x epoch … not working as expected, so i simply forgot it.
but since we are now in the 6.x epoch and 7.x is knocking at the door … chances are this feature has been improved. feel free to search for it

Click File > Clean up…

It removes temp work files.

meah … so i think we can open a feature request on this matter if is still useless …

Yeah, I tried Project > Refresh and File > Cleanup… before posting this question, but neither helped.