java.lang.NullPointerException when using Mobile Recorder

I am facing very same problem while trying to connect my emulator.
My appium version : 1.14.1 and Katalon Studio Version : 6.04, any help would be appreciated.

I am facing this very same problem while trying to connect my emulator and run mobile recording / spy mobile!!
My appium version : 1.14.1 and Katalon Studio Version : 6.04, any help would be appreciated.

Hi @asifuzzamanbappy,

As far as I know, Katalon Studio only supports up to Appium 1.12.1, so could you try downgrading to that version? I also recommend updating to at least Katalon Studio 6.2, but 6.3.3 is the latest official release.

Hope this helps,

Chris

Thanks a lot for your prompt reply, I really appreciate it. appium 1.12.1 setup getting processed, Katalon is suggesting to upgrade to version 6.3.3, would that be any problem?

Hi @asifuzzamanbappy,

I haven’t had any issues with Katalon Studio 6.3.3 so far and I’ve been using it for about a week.

– Chris

That’s reassuring. Funny Thing is after installing npm 1.12.1 I am getting this new error uIautomator2 is not initiated (Still using Katalon version 6.04) or do you think after katalon upgrade this would vanish??

katalon have no direct connection with node.js, it is dependant on the right java version only (openjdk8). i assume your issues are related to the third-party drivers used

Hi @asifuzzamanbappy,

As far as I can tell from the release notes, Katalon Studio 6.2.0 is the first version to support Appium 1.12.1, so I’m hoping that by upgrading, you’ll be back in sync.

– Chris

Thank you very much for your constant feedback on this issue, I really appreciate it. Unfortunately getting this annoying log [ No ‘uiautomator’ process has been found {“code”:“ECONNRESET”} ] while starting application for test, error. showing [ com.kms.katalon.core.appium.driver.SwipeableAndroidDriver.execute(SwipeableAndroidDriver.java:1)
at io.appium.java_client.AppiumDriver.execute(AppiumDriver.java:1)
at io.appium.java_client.android.AndroidDriver.execute(AndroidDriver.java:1) ] at the console along with others related to this kind.

I hope you find time to help me with this. Again, Many Thanks.

Hi @asifuzzamanbappy

Could you please share your test file script?

Thanks,

Chris

I am Just trying sample mobile recording project from katalon studio. I think its an issue with android sdk, when katalon studio downloaded only two folder [ build tools & platform tools ] got downloaded, is that how it’s supposed to be or something else is missing which consists uiautomatorviewer?

Hi @asifuzzamanbappy,

To make sure you have the latest Android SDK, you can try installing Android Studio - I don’t think Katalon comes with the necessary libraries.

Hope this helps,

Chris

You’re right, I got android-sdk-cli downloaded problem got solved. Thank you very much for all your feedback.

1 Like

@Chris_Trevarthen

I have got another favor to ask, how do I start a native android app with katalon studio? I have looked but nothing substantial been found regarding this topic directly. Say for example How Do I start Native calculator app (without .apk file ofcourse) from katalon? Many Thanks Upfront…

Hi @asifuzzamanbappy,

Check out this post and see if it helps. It’s for switching an application during test. You’ll need to know the package id of the native app you want to start:

– Chris

It helped a lot as I expected much. It resolved my problem with running application using application ID / Package Name - Dropping Names for noobs like me, Thanks Once Again for all your valued insights regarding this topic matter…

1 Like

@Chris_Trevarthen, @Zarashima
Hello,
I have the same issue:

Reason:

com.kms.katalon.core.exception.StepFailedException: Failed to tap on element 'Object Repository/01-Carrier/08-add remove clienti/aggiungi spedizioniere/XCUIElementTypeStaticText - adminagenzia2.com' (Root cause: java.lang.NullPointerException  

Katalon: 7.1.2
Appium: 1.15.1

Hi @fap

Is this happening when you’re recording steps in the Mobile Recorder? Could you share a screenshot and explanation of what you’re doing when you’re seeing this error?

Thanks,

Chris

Hi Chris,
I capture the elements with “spy mobile”; the elements are those, but fail to click and return that error. everything would seem to be solved using a “waitElementPresent”, but it’s strange

Thank you very much

Hi,
Below tutorial will help you on it