Issues using Basic Report Plugin

there are two command I used on window CMD,but they are all failed to generate the basic report under report folder.:cry:

katalon -noSplash -runMode=console -consoleLog -projectPath=“C:\Users\ivy\Katalon Studio\ciAPITest\test.prj” -retry=0 -testSuitePath=“Test Suites/TS_SmokeTest/TS_HappyFlow” -executionProfile=“default” -browserType=“Chrome” -apiKey=[000486e-cf14-4def-bcf5-23668e8bd0ac]
katalon -noSplash -runMode=console -consoleLog -projectPath=“C:\Users\ivy\Katalon Studio\ciAPITest\test.prj” -retry=0 -testSuitePath=“Test Suites/TS_SmokeTest/TS_HappyFlow” -executionProfile=“default” -browserType=“Chrome” -apiKey=[000486e-cf14-4def-bcf5-23668e8bd0ac]

Are you using the new basic report plugin? if so reload your plugins and ensure they’re updated.

I didn’t put my -apiKey inside brackets [ ] it’s just -apiKey=1234567-1222-2222-1234-2123111111
You should have received an error message stating invalid apiKey in the logs.

also since the apiKey is essentially a unique identifier for just you, I wouldn’t recommend posting it in public locations.

Thank you so much, you saved my day.

Is there any method to generate the report before TestSuiteListener end ?

Just to my previous post where I was asking for support because plugin installation did not work. My Katalon opened as default IE and in IE install does not work. I succeeded with Chrome.

Hi guys I am also battling with Katalon creating reports. I did everything that’s on the forum and I followed documentation to install the plugin and generate a apiKey but no luck. My report folders does not have a csv, junit or html report. image

Here’s the command I ran below:
katalon -noSplash -runMode=console -consoleLog -projectPath=“Q:\Reg_Katalon_Projects\RI 1803 FIN\RI 1803 FIN.prj” -retry=0 -testSuitePath=“Test Suites/Decision Service Batch NBC” -browserType=“Chrome” (headless) -apiKey=

It works now, for some reason my apiKey was not working!

Hi all,
I’m trying to get reports from a CI pipeline with Gitlab and Docker. After some successful tests in my local environment with no proxy in the middle, I then tried to execute my test suite on a remote environment with a proxy. Result? I get connection timed out in accessing during the reloading of the plugin.
I both set --config and all the options for the proxy in the cmd line and even from within Katalon Studio UI preferences but nothing: connection timed out.
Can anybody help out with this?
Thanks in advance.

I have the same issue, on Katalon 6.1.5 and 6.2 as well.


Any tip on how to work around this problem?
Any help is greatly appreciated.

Thanks again,

Maybe you should create a bug ticket for the dev-team, that the isn’t accessible behind a proxy?

1 Like

I´m having the same problem when i try to execute on a remote environment, are there any updates?