IP address

I need to add a Trusted IP Range to enable Katalon to logon to Salesforce. Suggestions?

Never mind. Fixed it! :smile:

How did you do this. I am being asked for verification every time i record a session. I tried adding the trusted IP range, still its not working.

Hi, I have tried it recently and the issue seems to be the same as you Supriya.
Sean, how were you able to do this.

Sean Potter said:

I need to add a Trusted IP Range to enable Katalon to logon to Salesforce. Suggestions?

How was this issue fixed. Each time I login to SF through katalon, it’s asking me the verification code. Please help

You need to consider a few things;

To reduce the number of identity verification prompts for your users, Salesforce recommends that you implement one or more of the following solutions.

  1. Add login IP restrictions to user profiles. Specify a range of trusted IP addresses from which profile users can log in without being prompted to verify their identity. For detailed steps on how to do this, review theRestrict Login IP Addresses in the Original Profile User Interface article.

  2. **Change browser privacy settings to save cookies for Salesforce sites. **This may be done at the admin or end user level. Before making any changes in your browser, verify with your IT department that the changes comply with your security policies.

3.** Set trusted IP ranges for your org**. Specify a range of IP addresses from which all of your users can log in without being prompted to verify their identity. For detailed steps on how you may do this, review the Set Trusted IP Ranges for Your Organization article. (https://help.salesforce.com/apex/HTViewHelpDoc?id=security_networkaccess.htm&language=en_US)

To disable Email activation for the org, you can set the IP ranges for the org as below.
Security Controls->Network Access->New
Start IP address - 0.0.0.0
End IP address - 255.255.255.255

After adding the IP ranges the system will never asks the Identify Confirmation. You can set the IP ranges for individual profiles too (profiles->Ip ranges section)

In some cases; this might be deemed as a breach of the companies security policy - but it will technically work.

In all cases; the browser must also allow cookies to be stored; and must not clear them before logging into Salesforce after a successfully authenticated session.

Hi Scott,

adding a trusted IP worked for me as well, thanks!