IOS Unable to start application


#1

I followed the instructions from the below video in order to install the IOS for katalon.

When i tried to complete the IOS setup, one the last step that you have to run the command in order to see your device on local i had the message on the screen below. Can someone help me ? thank you


#2

Hi @dimitrios.d,

Can you try removing the platform part of the -destination parameter so it’s just -destination 'id=ff18deb...'?

Hope this helps,

Chris


#3

When i tried to remove the platform part the xcodebuild command cannot be executed because its seems that the platform part is a mandatory field. After trying executing the command, the xcodebuild return us usage instructions. Thus the command needs the platform field to be executed.
Any other help ???


#4

Hi @dimitrios.d,

That’s interesting that you’re getting an error about the usage. Here is the command I’m running:

xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination 'id=AA65C6FC-9E75-48AB-AB1E-A3FD696D0BD6' test

I’m using Xcode 10.2.

– Chris