IOS device version 12.2 getting error "'null' cannot be coerced to a valid version number"


#1

While trying to install an IOS app and test it using Katalon Studio, I am getting an error “‘null’ cannot be coerced to a valid version number”

I am using Katalon Studio 6.1.2, Xcode 10.0 and Appium 1.12.1
The IOS device I am running has 12.2 version

After searching online I understood that I need to see 12.2 in the list when I run “xcrun simctl list” but I was seeing 5.0 and 12.0

The simulators were all in 12.0 and hence the app is running on it and as the device is running 12.2, the app is not running on it. How can we solve this and is there any work around?

If this is true, can’t we run the IOS automation on versions other than 5.0 and 12.0?