Ios app testing: app keeps crashing and the testing never starts


#1

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint

import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase

import static com.kms.katalon.core.testdata.TestDataFactory.findTestData

import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject

import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint

import com.kms.katalon.core.checkpoint.CheckpointFactory as CheckpointFactory

import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as MobileBuiltInKeywords

import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as Mobile

import com.kms.katalon.core.model.FailureHandling as FailureHandling

import com.kms.katalon.core.testcase.TestCase as TestCase

import com.kms.katalon.core.testcase.TestCaseFactory as TestCaseFactory

import com.kms.katalon.core.testdata.TestData as TestData

import com.kms.katalon.core.testdata.TestDataFactory as TestDataFactory

import com.kms.katalon.core.testobject.ObjectRepository as ObjectRepository

import com.kms.katalon.core.testobject.TestObject as TestObject

import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WSBuiltInKeywords

import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUiBuiltInKeywords

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI

import internal.GlobalVariable as GlobalVariable

import com.kms.katalon.core.util.internal.PathUtil as PathUtil

import com.kms.katalon.core.configuration.RunConfiguration as RunConfiguration

def envApk = “TestData/bms.ipa”

def appPath = PathUtil.relativeToAbsolutePath(envApk, RunConfiguration.getProjectDir())

Mobile.startApplication(appPath, false)

Screen Shot 2018-05-10 at 6.38.24 PM.png


#2

Hi Pritam,

Please try below workaround

Go to terminal

$ cd “path to webdriveragent folder”

$ xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination ‘id=device or simulator udid’ test

If above command doesnt work please setup webdriver agent using this link

https://docs.katalon.com/display/KD/Mobile+on+macOS


#3

I have followed the setup procedure properly, I think the issue is in the ios app then the code