Improper Execution Profiles to be shown as invalid in the Tests Explorer


At startup of Katalon, it would be helpful if it would mention when it cannot parse Profiles files instead of just ignoring them. See screenshot below of current behavior.

It took me some time to figure out that the files were not displayed because they were no longer valid XMLs.


1 Like

I assume you’ve tried a File/Clean up (file menu) followed by Refresh on the Explorer (right click the explorer)?

Hi Russ,

Thanks for the suggestion. I already tried those things with no success. Even more, I tried all sorts of workarounds - renaming in file system, cutting and pasting away and back into the folder. I also deleted all the files/dirs listed in .gitignore hoping that the problem will be fixed when those are re-made. No success. I am all out of ideas.

1 Like


So… (treading carefully…) what does Kat do if you try creating another profile with the same name as one that it refuses to list while it’s actually present on disk? IOW, try creating bs_qa03 again while it’s present on disk…

I’m guessing there must be something else hidden away in the structure that profiles depend on. @devalex88 - any ideas?

1 Like


I tried your suggestion and it overwritten the existing file, appearing as an empty profile in Katalon. However, it only appeared in the Tests Explorer section of Katalon until the first pull request from Git. Afterwards - poff, gone again, but still in the file system.


I was finally able to figure out what was wrong. Long story short - the execution profiles were no longer valid XMLs. That is why Katalon was not loading them. The problem was in the files.

No user data was lost. So not a bug, but maybe an improvement opportunity would be to show the files as invalid.

Cheers and thanks for the help!

1 Like

@Russ_Thomas done.