If statement execution is taking 42 minutes after upgrading to Xcode 11,iOS 13 and Appium 1.15

Hi @satish1607,

You mentioned that the verifyElementExist is taking a long time if it’s false. Is that something that only happens if it’s the last call during the test?

– Chris

Thanks chris for looking into this issue, my problems are following:

Failure case is not executing its keep on executing for more than 40 minutes
If else is not executing for failure case its taking more than 40 minutes
Any true or false its taking 40 minutes
I have tried even downgrading Appium like 1.15.0, 1.15.1 etc

Its not reporting the failure case on specified timeout


Any update why Katalon is not reporting failure cases, What else I can do so that Katalon should start working like before…



Hi @satish1607,

I just tried the verifyElementExists on a non-existent element using iOS 13.1 and Appium 1.15.1. For me, it immediately failed when it couldn’t find the element. Right now, it doesn’t seem like we can reproduce the issue outside of your app.

A few more options to try:

  1. Try creating a new iOS sample test project (File->New Sample Project->Sample Mobile iOS Tests Project). In that test project, try changing one of the test objects so that the verifyElementText tests will fail. Check if it is taking as long as it does on your test to fail.

  2. Remove your verifyElementExists check and just try to interact with the element. If the element can’t be interacted with, then it doesn’t exist, and will fail - that can serve as your verification; if the test moves beyond that part, then you know the element exists.

  3. Share the app file you’re testing and your test script so we can see if it’s an issue with the app or the environment.

  4. Create a simple app and test that produce the same issue and share those.

– Chris

Thanks Chris for looking in to this issue. Even simple failure also not reporting.

How do I delete and re create the setup again if you have any documents please do let me know.

Satish Kumar Pal

Hi @satish1607,

There is a video tutorial with text steps on how to setup Katalon to iOS testing. You could try setting this up from the beginning to make sure everything is ok: https://docs.katalon.com/katalon-studio/videos/ios_mobile_testing.html

Hope this helps,


Thanks Chris for your replay.

I have tried all the steps now I am getting below error

Unable to start application : Reason: String index out of range -6 

ava.util.concurrent.ExecutionException: java.lang.StringIndexOutOfBoundsException: String index out of range: -6

at com.kms.katalon.composer.components.impl.dialogs.ProgressMonitorDialogWithThread.runAndWait(ProgressMonitorDialogWithThread.java:49)

at com.kms.katalon.composer.mobile.objectspy.components.MobileLocalAppComposite$12.run(MobileLocalAppComposite.java:474)

at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)

Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -6

at com.kms.katalon.core.appium.driver.AppiumDriverManager.getXCodeVersion(AppiumDriverManager.java:695)

at com.kms.katalon.core.mobile.keyword.internal.MobileDriverFactory.createCapabilities(MobileDriverFactory.java:265)

at com.kms.katalon.core.mobile.keyword.internal.MobileDriverFactory.startLocalMobileDriver(MobileDriverFactory.java:459)

at com.kms.katalon.composer.mobile.objectspy.dialog.MobileInspectorController.startMobileApp(MobileInspectorController.java:191)

at com.kms.katalon.composer.mobile.objectspy.components.MobileLocalAppComposite$12$1.call(MobileLocalAppComposite.java:479)

at com.kms.katalon.composer.components.impl.dialogs.ProgressMonitorDialogWithThread.startThreadAndWait(ProgressMonitorDialogWithThread.java:36)

at com.kms.katalon.composer.components.impl.dialogs.ProgressMonitorDialogWithThread.runAndWait(ProgressMonitorDialogWithThread.java:48)

... 2 more

Could you please let me know why I am getting this error


Hi @satish1607,

I’ve seen that error when the version of Appium can’t figure out the version of Xcode. Could you confirm:

  • Version of appium you have installed by running appium -v from the Terminal?
  • Version of Xcode you have installed by running xcode-select -p from the Terminal?
  • Version of Katalon Studio you’re running?



Hi Chris,

Please find the screenshot below

Katalon Studio v 7.0.4

Finally my issue is resolved and Katalon Studio is working fine. I have done the followings
Upgraded my Xcode 11.0 to 11.1
Downgraded my Appium 1.15.1 to 1.15.0
Katalon Studio version 7.0.4.

Its working.


Hello @satish1607

Thank you so much for your kind sharing.

Can you please also provide the version of Java, node, and npm you use? Just would like to ensure the compatible version.


Please find the details from above and same I am updating here:

Javac 13.0.1
node 12.13.0
Appium 1.15


last time i checked, last supported version by katalon for java is 1.8.x …

Hi @satish1607

I am experiencing the issue "could not build module ‘Routing HTTPServer’ " while building up the WebDriverAgentLib. I searched the solution on Google and found it may be version compatibility issue. Have you experienced this?

I tried to update Carthage and have no luck


Please follow this doc to build WebDriverAgent: https://docs.katalon.com/katalon-studio/docs/installing-webdriveragent-for-ios-devices.html

Hi @duyluong

I did follow this instruction and build Lib and Runner successfully without any error and warning message.

However, I still face this issue Error Domain=NSCocoaErrorDomain Code=4 "The folder “WebDriverAgentRunner_iphoneos13.2-arm64.xctestrun” doesn’t exist , with appium 1.15/1.15.1, Katalon 7.06 while runing test on real iOS devices.

I am not sure whether it is version compatibility issue because I tried some possible solutions on Github but have no luck.

Some people still recommend to use Katalon experimental, which cannot run test on iOS 13.

So which version of Appium and Kalaton is the most stable and capable to run test on iOS 13?

Kind Regards,


KS is running fine with following versions:

KS 7.0.4
Appium 1.15.0
iOS : 13.1.3
Xcode 11.1
Please do let me know if you are facing any issue.

Hi @satish1607

Thanks for your reply.
Have you encountered this?
“An unknown server-side error occurred while processing the command. Original error: Did not get any response after 300s”

It took 10 mins to timeout and report this error. The previous steps were: 1. open browser 2. navigate to url 3.Click (stop here)

@ppppacchan, which version of Appium & Katalon studio are you using?

I tried KS 7.0.4/7.0.6/7.010 and all of them have this issue
I also tried Appium 1.15.0/1.15.1/1.16.2Beta