I can't spy or record on android mobile

Vinh Nguyen said:

Sameer Singh said:

This is an error related to this object can’t be found, not related to any of Katalon Studio execution yet. Can you see if ‘android.widget.Button0 - continue’ object is available from your Test Explorers?

Hi,
Yes, it is available from Test Explorers, also as I mentioned same code works on devices with android version 5, 6.
So, maybe it is an issue with android version 7.0nrd90m with Redmi Note 4 devices.

Hi,
How to do a website testing on mobile browser/M6. can anyone pls share the steps

Hello,
i’m not able to spy elements on device Huawei Nexus 6P(8.0.0), when i start recording then an overlay appears ‘progress information’ about ‘Capturing obejects…’ and stays for long time with displaying moving progress bar at the overlay.
will you please look into this?
Thanks in advance.

i have same problem with this topic… i’ve tried 3 different product application and it always show SWTException when using spy android and NullPointerException when using record android … can you help me what is wrong with this and how to fix this? ty

image.png

2 Likes

Hello,
I had the same issue since I updated Appium 1.8.1 to 1.9.0 through the command: npm install -g appium
My android projects no longer work with this new version (including Spy and mobile recorder)

So, i rollback to version 1.8.1 through: npm install -g appium@1.8.1

If this issue is “normal” because katalon 5.6.1 is not yet compatible with Appium 1.9, I suggest that the Katalon team update the page: https://www.katalon.com/videos/android-setup-windows/

by changing: “npm install -g appium” by “npm install -g appium@1.8.1”

Otherwise new users of Katalon (mobile) may be disturbed!
When do you expect a new version of katalon supporting appium 1.9 ?
Thanks

5 Likes

Hello, I am facing the same issue running on iPhone 6S.

Solved by running the command below to revert back to appium version 1.8.1
npm install -g appium@1.8.1

2018-08-29_08-08-34.png

Currently I’m using:
Katalon: v5.7.0
Appium: v1.9.0
NodeJS: v8.11.4
And I have a similar problem when I want to run the mobile recorder. Please help me!!!

2222.png

2 Likes

I have the similar issue as well

  • Appium version :** v1.9.0**

  • Mobile platform/version under test: Oreo (8.1.0)

  • Real device or emulator/simulator: OnePlus One

35m[Appium][39m Welcome to Appium v1.9.0

[35m[Appium][39m Non-default server args:

[35m[Appium][39m port: 55495

[35m[Appium][39m loglevel: info

[35m[Appium][39m chromeDriverPort: 55496

[35m[Appium][39m tmpDir: C:\Users\cinesoft\AppData\Local\Temp\\Katalon\Appium\Temp1536558028422

[35m[Appium][39m Appium REST http interface listener started on 0.0.0.0:55495

[35m[HTTP][39m [37m–>[39m [37mGET[39m [37m/wd/hub/status[39m

[35m[HTTP][39m [90m{}[39m

[35m[HTTP][39m [37m<-- GET /wd/hub/status [39m[32m200[39m [90m99 ms - 67[39m

[35m[HTTP][39m [90m[39m

[35m[HTTP][39m [37m–>[39m [37mGET[39m [37m/wd/hub/status[39m

[35m[HTTP][39m [90m{}[39m

[35m[HTTP][39m [37m<-- GET /wd/hub/status [39m[32m200[39m [90m59 ms - 67[39m

[35m[HTTP][39m [90m[39m

[35m[HTTP][39m [37m–>[39m [37mPOST[39m [37m/wd/hub/session[39m

[35m[HTTP][39m [90m{“desiredCapabilities”:{“app”:“C:\\Users\\cinesoft\\Desktop\\anand_media_testV2.3.apk”,“autoGrantPermissions”:true,“automationName”:“uiautomator2”,“deviceName”:“OnePlus A0001 (Android 8.1.0)”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platform”:“ANDROID”,“platformName”:“Android”,“udid”:“d95b2fd3”},“capabilities”:{“desiredCapabilities”:{“app”:“C:\\Users\\cinesoft\\Desktop\\anand_media_testV2.3.apk”,“autoGrantPermissions”:true,“automationName”:“uiautomator2”,“deviceName”:“OnePlus A0001 (Android 8.1.0)”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platform”:“ANDROID”,“platformName”:“Android”,“udid”:“d95b2fd3”},“firstMatch”:[{“platformName”:“android”}]}}[39m

[35m[Appium][39m Could not parse W3C capabilities: ‘deviceName’ can’t be blank

[35m[Appium][39m Trying to fix W3C capabilities by merging them with JSONWP caps

[35m[BaseDriver][39m The capabilities [“app”,“autoGrantPermissions”,“automationName”,“deviceName”,“fullReset”,“newCommandTimeout”,“noReset”,“platform”,“udid”] are not standard capabilities and should have an extension prefix

[35m[Appium][39m Creating new AndroidUiautomator2Driver (v1.16.0) session

[35m[Appium][39m Capabilities:

[35m[Appium][39m app: C:\Users\cinesoft\Desktop\anand_media_testV2.3.apk

[35m[Appium][39m autoGrantPermissions: true

[35m[Appium][39m automationName: uiautomator2

[35m[Appium][39m deviceName: OnePlus A0001 (Android 8.1.0)

[35m[Appium][39m fullReset: false

[35m[Appium][39m newCommandTimeout: 1800

[35m[Appium][39m noReset: true

[35m[Appium][39m platform: ANDROID

[35m[Appium][39m udid: d95b2fd3

[35m[Appium][39m platformName: android

[35m[BaseDriver][39m The following capabilities were provided, but are not recognized by appium: platform.

[35m[BaseDriver][39m Session created with session id: d4b96fb3-070c-44f1-9afe-aa607d92e4d1

[35m[BaseDriver][39m Using local app ‘C:\Users\cinesoft\Desktop\anand_media_testV2.3.apk’

[35m[AndroidDriver][39m Java version is: 1.8.0_102

[35m[ADB][39m Checking whether adb is present

[35m[ADB][39m Found 1 ‘build-tools’ folders under ‘C:\Users\cinesoft\.katalon\tools\android_sdk’ (newest first):

[35m[ADB][39m C:/Users/cinesoft/.katalon/tools/android_sdk/build-tools/28.0.2

[35m[ADB][39m Using adb.exe from C:\Users\cinesoft\.katalon\tools\android_sdk\platform-tools\adb.exe

[35m[AndroidDriver][39m Retrieving device list

[35m[AndroidDriver][39m Using device: d95b2fd3

[35m[ADB][39m Using the alternative activity name detection method because of: Could not find apkanalyzer.bat in C:\Users\cinesoft\.katalon\tools\android_sdk\platform-tools\apkanalyzer.bat,C:\Users\cinesoft\.katalon\tools\android_sdk\emulator\apkanalyzer.bat,C:\Users\cinesoft\.katalon\tools\android_sdk\tools\apkanalyzer.bat,C:\Users\cinesoft\.katalon\tools\android_sdk\tools\bin\apkanalyzer.bat,C:\Users\cinesoft\.katalon\tools\android_sdk\build-tools\28.0.2\apkanalyzer.bat. Do you have the Android SDK installed at ‘C:\Users\cinesoft\.katalon\tools\android_sdk’?

[35m[ADB][39m Checking whether aapt is present

[35m[ADB][39m Using aapt.exe from C:\Users\cinesoft\.katalon\tools\android_sdk\build-tools\28.0.2\aapt.exe

[35m[ADB][39m Extracting package and launch activity from manifest

[35m[ADB][39m Package name: ‘com.cinesoft.anandmedia.mobile’

[35m[ADB][39m Main activity name: ‘com.mobile.root.anandmediamobile.view.activity.SplashActivity’

[35m[ADB][39m Getting device platform version

[35m[ADB][39m Using apksigner.bat from C:\Users\cinesoft\.katalon\tools\android_sdk\build-tools\28.0.2\apksigner.bat

[35m[ADB][39m Checking whether zipalign is present

[35m[ADB][39m Using zipalign.exe from C:\Users\cinesoft\.katalon\tools\android_sdk\build-tools\28.0.2\zipalign.exe

[35m[ADB][39m io.appium.uiautomator2.server was successfully uninstalled

[35m[ADB][39m io.appium.uiautomator2.server.test was successfully uninstalled

[35m[AndroidDriver][39m setDeviceLanguageCountry requires language or country.

[35m[AndroidDriver][39m Got language: ‘null’ and country: ‘null’

[35m[ADB][39m Successfully extracted 123 strings from ‘C:\Users\cinesoft\Desktop\anand_media_testV2.3.apk’ resources for ‘(default)’ configuration

[35m[UiAutomator2][39m Starting uiautomator2 server 1.15.1

[35m[UiAutomator2][39m Using UIAutomator2 server from ‘C:\Users\cinesoft\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.15.1.apk’ and test from ‘C:\Users\cinesoft\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-debug-androidTest.apk’

[35m[UiAutomator2][39m Running command: ‘adb -s d95b2fd3 shell am instrument -w io.appium.uiautomator2.server.test/android.support.test.runner.AndroidJUnitRunner’

[35m[UiAutomator2][39m Waiting up to 20000ms for UiAutomator2 to be online…

[35m[AndroidDriver][39m Screen already unlocked, doing nothing

[35m[UiAutomator2][39m UiAutomator2 did not start the activity we were waiting for, ‘com.cinesoft.anandmedia.mobile/com.mobile.root.anandmediamobile.view.activity.SplashActivity’. Starting it ourselves

Hello,

Please uninstall Appium and install version 1.8 it worked for me.

@ Walter Michael Fernandes
Thanks for the update,let me check the same scenario by installing version 1.8
@“Katalon Team”
Please do update the Katalon version which is compatible with Appium 1.9 as suggested by #Ctof

2 Likes

I am having the same issue running Appium version 1.9.0 or 1.9.1 on my Macbook Pro. I attempted to revert back to Appium 1.8.1 but when I do, the Xcode WebDriverAgent project fails to build.

Is there a 1.8.1 configuration for Mac (Node, Carthage, etc version that works)?

1 Like

Update: So I was able to resolve this on my Macbook Pro running Mojave, by doing the following (figured I would give more information…even though it took me about a day of pulling my hair out to find the right combination…)

1. Install Appium Version 1.8.1
2. Uninstall XCODE version 10
3. Download and Install XCODE 9.4.1 (URL: https://developer.apple.com/downloads/)
4. Ensure Apple ID is still associated with XCODE version
5. Re-run MKDIR and Bootstrap Script in Webdriver directory **(follow instructions on:https://medium.com/@katalon_studio/setting-up-mobile-automation-project-in-macos-with-katalon-studio-11aab3ff0efe)**6. Re-build the Webdriver agent project

That should do it.

NOTE: It would be nice though if Katalon supported 1.9.0 and 1.9.1. In addition, it should be made clear on these forums that if you downgrade to appium 1.8.1 but you are running XCODE 10, you will probably receive build errors. Thought I would post that here, to avoid all of you having the same struggles right now.

2 Likes

Hi Kevin,

Glad you got it working. You can still run Xcode 10 for development, but then switch to Xcode 9.4.1 for any system tools:

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

Assuming you have Xcode 9.4.1 installed as “Xcode.app”.

Hope this helps,

Chris

Chris:

I did not know that I could have two instances of XCODE installed at one time. Maybe that is specific to mac. I am used to Windows if that is the case, where you can only have one version of the application installed.

When you say you can use Xcode 10 for development; but 9.4.1 for system tools; can you define further. Would system tools include Katalon?

Also any additional instructions/steps or writeup on how switching works (as I am clearly a novice) would be helpful.

Hi Kevin,

You can find older versions of Xcode here: https://developer.apple.com/download/more/

If you download and install from there, you’ll be asked if you want to keep both versions of Xcode, in which case, you should choose Keep Both. You’ll be able to rename one or both of them (I recommend leaving the newest App Store version as “Xcode.app” and renaming the other one to “Xcode9.4.app” - leaving spaces out, because it just gets messy).

The problem then is that some apps, like Katalon Studio, don’t yet support Xcode 10, so you have to make it so that the default Xcode install is the older one. So in the case of having a copy of Xcode named “Xcode9.4.app”, you can change the default system Xcode:

1. Open a new Terminal window
2. Type:

sudo xcode-select -s /Applications/Xcode9.4.app/Contents/Developer

3. When prompted for a password, enter your system/login password for your machine
4. You can then use Katalon Studio to create and run tests while still having Xcode 10 for any app development.

None of the system tools include Katalon Studio, but Katalon *uses* Xcode’s utilities to perform tasks. When you start an object capture or test, it checks that you have a supported version of Xcode. Unfortunately, Katalon Studio doesn’t support Xcode 10 yet.

- Chris

Hi,

my app don’t open correctly in katalon device view but it’s open correctly on my device.
can you help me please.

Mobile Object Spy 2018-10-31 11-19-58.png

Hi Yassine,

Note that you need to click the “Capture Object” button in order to get the Device View to sync up with what’s showing on your phone or simulator. You’ll need to click that button every time you interact with your app.

Hope this helps,

Chris

Facing the problem of SWTException: Failed to execute runnable (org.eclipse.core.runtime.AssertionFailedException: null argument:)

I was trying mobile spy for the sample android mobile application (provided in Katalon by default - APIDemos.apk)

Can someone please guide me here, I’m just new to automation and katalon.

Thanks & Regards,
Tipu.

Hi @musman

Can you confirm which version of Appium you’re using? For maximum compatibility, it’s recommended that you use Appium Server 1.8.1 (note: this is not the same version as Appium Desktop, in which case you’ll need 1.6.3).

Here are some troubleshooting tips that might be helpful:

Hope this helps,

Chris

Hi @Chris_Trevarthen … Thanks for the reply and the tips for troubleshooting, I am gonna check them as well.

Currently, im using appium version 1.12.1.

Do i need to downgrade the current appium version?

Thanks for the help.