How to setup HTTP timeout for Web Service API

I don’t have response from API because of too short HTTP timeout:

Elapsed time: 19.466s
Test Cases/Game - bad connection between GS and API FAILED.
Reason:
com.kms.katalon.core.exception.StepFailedException: Unable to send request (Root cause: org.apache.http.NoHttpResponseException: api.cd.com:4010 failed to respond

Hi @Dmitriy,
We haven’t supported setting timeout for API requests. We will consider to implement this feature in upcoming releases and get you noticed if there is any update.

Hi @huynguyen, thanks a lot for the answer. Looking forward to the release with this feature!

anyone have a workaround to set timeout for API sendRequest.
My automation test cases hang because API doesn’t return response in some case

I would also like to have that possibility.
I have a request that i need to test that takes an enormous amount of time to be completed. Which is normal for the test case.

But the request quits abruptly without waiting for completion.
I can see on the server that the request is still ongoing. But it puts a hurdle on my automated tests to not be able to set the timeout

Hello everyone,

Katalon Studio 7.6 supports setting timeout and maximum response size for API requests as Katalon Studio Enterprise features. Please refer to release notes for more details.

Happy Testing

Jass