How to check versions of Library Management Jars

Hi All,

While running my project , getting this error

java.util.concurrent.ExecutionException: com.fasterxml.jackson.databind.JsonMappingException: Scala module 2.10.0 requires Jackson Databind version >= 2.10.0 and < 2.11.0

I have added this in Library Management

I want to check scala version

Note: This started after updating katalon : 8.6.8 , It was working before

1 Like

I don’t understand your question.
What is “scala version” you mean.

You added the jackson-all.jar. Possibly it is a wrong choice.

The jackson-all.jar is the ALL-IN-ONE jar that includes everything that the FasterXML Jackson project provides. The jar includes the classess of the jackson-module-scala as well. The message implies that the jar requires something complicated.

You do not need Sclala support in Katalon Studio. I suppose that adding the jackson-all.jar just complicates things for you. You should be more specific to choose which jar you want to add into the project.