How do I delete empty data file?

Hi all!
I’m unable to delete an empty data file. The file isn’t used anywhere. When I click “Open containing folder”, it takes me to drive C but no specific location. I cannot open or rename this file either. I refreshed the project, restarted Katalon which didn’t help.


Can you see any error? When you right click on it, did you see delete option? Or you can Open containing folder of the whole Data file, and see if that empty file exists.

1 Like

Hi @natallia.dyer, welcome to the Community!

Following @Elly_Tran’s instruction, I saw the option of “Delete” when right-clicking on a data file and successfully deleted it.

Yes, I’ve tried right click and Delete - nothing happens. When I open containing folder, it just takes me to drive C and no specific location.

It doesn’t delete for me.

Hi @natallia.dyer,

Katalon may have lost the link to the data file, so do the following on Windows.

  1. Quit Katalon.
  2. Backup your project using Git or some other archiving tool.
  3. Using the Windows ‘File Explorer’ open the folder where the data file is stored.
    For example: C:\Users\JohnDoe\ProjectName\Data Files\FolderName\dataFile
  4. Delete the dataFile.
  5. Open Katalon.
1 Like

Thank you, @dave.evers I tried to open the data files folder in VS Code - the file in question wasn’t there.
Looked up file directory using cmd - the file was not shown.
Went to File Explorer, data files folder and chose to show hidden files - the file was not shown.
My conclusion is the file doesn’t exist, it’s been deleted but for some reason Katalon is showing it. It must be a bug.

Hi @natallia.dyer,
Have you tried adding data to the data file, saving and then deleting?

Sadly, I cannot add any data since I can’t open that data file. I opened a support ticket and I will post the resolution here when found.

Here is what happened. “New Test Data” file was actually MRA-010 in Data Files in File Explorer data files folder. I screenshotted and then deleted all MRA-010 data files in the folder on my machine. That automatically deleted “New Test Data” in Katalon Studio.
It is weird that the files had different names and MRA-010 appeared to be “New Test Data” file in Katalon.

1 Like

This looks similar to the following case:

May be due to the same cause.