Git Issue - git-upload-pack not permitted

I’ve just switched to using a new Git Repo on github.
I can connect perfectly well from WIndows Git Desktop with email / password, and clone / commit / push / pull.
On katalon however, with the exact same details I get
git-upload-pack not permitted

either on trying to Clone it, or if I use Desktop Client for cloning, when I try to push anything from katalon.
Error log below…
Any ideas what this is and how I can fix it please?

!ENTRY org.eclipse.egit.ui 4 0 2021-08-14 09:38:01.746
!MESSAGE git-upload-pack not permitted
org.eclipse.jgit.api.errors.TransportException: git-upload-pack not permitted
at org.eclipse.jgit.api.LsRemoteCommand.execute(
at org.eclipse.egit.ui.internal.components.RefContentAssistProvider$
at org.eclipse.jface.operation.ModalContext$
Caused by: org.eclipse.jgit.errors.TransportException: git-upload-pack not permitted
at org.eclipse.jgit.transport.TransportHttp.connect(
at org.eclipse.jgit.transport.TransportHttp.openFetch(
at org.eclipse.jgit.api.LsRemoteCommand.execute(
… 4 more

!ENTRY org.eclipse.egit.core 4 0 2021-08-14 09:38:10.747
!MESSAGE An exception occurred during push on URI git-receive-pack not permitted
org.eclipse.jgit.errors.TransportException: git-receive-pack not permitted
at org.eclipse.jgit.transport.TransportHttp.connect(
at org.eclipse.jgit.transport.TransportHttp.openPush(
at org.eclipse.jgit.transport.PushProcess.execute(
at org.eclipse.jgit.transport.Transport.push(
at com.kms.katalon.composer.integration.git.internal.push.CustomConfirmationPage$
at org.eclipse.jface.operation.ModalContext$

I got the same issue today, and solved by use personal access token and put the token as password when I clone new project from github.

1 Like

I tried the personal access token, but I still get the same error, any other fixes?

1 Like

same problem am also facing. After entering personal access token still facing issue of Gitlab not permitted error.

Any fix available for this error?

Perhaps the following Stackoverflow issue will help:

Since August 13, 2021, GitHub does not support authentication via HTTPS with your GitHub account password for security reasons anymore. Instead, in Eclipse, when pushing to a GitHub repository or when fetching from a private repository, you will get a git-upload-pack not permitted on '' error.

Hello All,

Please go to the repository and check the below (snap). Your issue will resolve