Getting Coreexception while opening the project

HI ,

I am trying to open the project in my local system(Cloned from git).
I am getting an error : ‘Unable to open project. Reason:CoreException’
org.eclipse.core.runtime.CoreException: Error processing changed links in project description file.
at org.eclipse.core.internal.resources.Project.open(Project.java:1047)
at org.eclipse.core.internal.resources.Project.open(Project.java:1087)
at com.kms.katalon.groovy.util.GroovyUtil.initGroovyProjectDescription(GroovyUtil.java:589)
at com.kms.katalon.groovy.util.GroovyUtil.initGroovyProject(GroovyUtil.java:159)
at com.kms.katalon.controller.ProjectController.openProjectForUI(ProjectController.java:90)
at com.kms.katalon.composer.project.handlers.OpenProjectHandler$1.run(OpenProjectHandler.java:165)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
Contains: : is an invalid character in resource name ‘C:’.
Contains: : is an invalid character in resource name ‘C:’.

Can you please help on this. I am stuck in my automation . I have spent almost 2 days to figure out.
I changed the project path in .prj and console2Properties file.
It still did not work.

Thanks in advance.
Chandana

@cnagaraju I am not sure if this will work but can you go to the project folder, right-click and then unselect read-only.

Then open Katalon again and try to load the project again.

@cnagaraju For me most times it was enough to delete the .project File and reopen the project.

I tried deleting the all the entries under “linkedResources” tag from .project file and it worked for me. Make sure when you push changes to git back don’t select this file.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.