failed to activate for Katalon studio 5.4 on linux system

When i try to execute my testcase on linux system through following command,
./katalon -runMode=console -consoleLog -projectPath=“/.prj” -retry=0 -testSuitePath=“” -browserType=“Chrome (headless)”

It is asking to pass email and password to activate katalon studio.
“Katalon is not activated. Please use -email and -password to pass in your account!”

But if i am passing the email and password, i am getting the following response.
"Request sent successfully.

Request sent successfully.

Network error! Cannot execute activation."

But if i provide incorrect emailid then it is saying “email id/Password is incorrect”.
That means Katalon is successfully receiving the request to activate the system.
Now I am not able to proceed on linux system.
Can someone please suggest me something, so i can atleast proceed.

Do you have any proxy settings configured from your side? If so, you may need to pass proxy settings as console mode commands in your command line: https://docs.katalon.com/display/KD/Console+Mode+Execution#ConsoleModeExecution-KatalonCommandLineoptions

Example:

katalon -noSplash  -runMode=console -consoleLog -noExit -projectPath="C:\Users\Katalon Studio\Project\YourProject.prj" -retry=0 -testSuitePath="Test Suites/TS_RegressionTest" -browserType="Chrome (headless)" --config -proxy.option=MANUAL_CONFIG -proxy.server.type=HTTP -proxy.server.address="http://192.168.12.32" -proxy.server.port="8888"

No Vinh. Its on AWS and there is no proxy. and in case of Invalid emailId, I am getting the proper response.
and just want to mention its working fine on windows system.

Piyush Tripathi said:

When i try to execute my testcase on linux system through following command,
./katalon -runMode=console -consoleLog -projectPath="/.prj" -retry=0 -testSuitePath="" -browserType=“Chrome (headless)”

It is asking to pass email and password to activate katalon studio.
“Katalon is not activated. Please use -email and -password to pass in your account!”

But if i am passing the email and password, i am getting the following response.
"Request sent successfully.

Request sent successfully.

Network error! Cannot execute activation."

But if i provide incorrect emailid then it is saying “email id/Password is incorrect”.
That means Katalon is successfully receiving the request to activate the system.
Now I am not able to proceed on linux system.

How do you pass the credentials? i get the same activation error…

@divya Pass

-email="<emailId>" -password="<Password>"

Complete command is

./katalon -noSplash  -runMode=console -consoleLog -email="<emailId>" -password="<Password>" -projectPath="<ProjectPath>.prj" -retry=0 -testSuitePath="<Test Suites>" -browserType="Chrome (headless)"

I get a similar error and also not behind a proxy.

error message:

Request sent successfully.
Request sent successfully.
Email or password is invalid!

I added -consoleLog to the command got the following ( there were quite a lot of similar messages ie “…Could not install bundle…” - i have trimmed to the last 4 )

...!ENTRY org.eclipse.update.configurator 4 0 2018-05-01 17:11:20.056
!MESSAGE Could not install bundle plugins/org.apache.poi.ooxml.schemas_3.9.0.v201405241750.jar   A bundle is already installed with the name "org.apache.poi.ooxml.schemas" and version "3.9.0.v201405241750"
!ENTRY org.eclipse.update.configurator 4 0 2018-05-01 17:11:20.077
!MESSAGE Could not install bundle plugins/org.eclipse.ui.browser_3.5.2.v20161114-0210.jar   A bundle is already installed with the name "org.eclipse.ui.browser" and version "3.5.2.v20161114-0210"
!ENTRY org.eclipse.update.configurator 4 0 2018-05-01 17:11:20.092
!MESSAGE Could not install bundle plugins/org.eclipse.equinox.concurrent_1.1.0.v20130327-1442.jar   A bundle is already installed with the name "org.eclipse.equinox.concurrent" and version "1.1.0.v20130327-1442"
!ENTRY org.eclipse.update.configurator 4 0 2018-05-01 17:11:20.110
!MESSAGE Could not install bundle plugins/org.apache.commons.io_2.4.0.jar   A bundle is already installed with the name "org.apache.commons.io" and version "2.4.0"

My email and password are correct ( the same as i use to login to the forum ) - is the above causing the error?

1 Like

Getting similar error - “Email or password is invalid!”, the same is working fine on windows machine.

I have just tried running the script on ubuntu and the tests ran!

I changed my password again on my Mac, where i was temporarily locked out ( i waited 5 - 10 minutes and able to log back in again ) - this happened right after i tried to log back in with my new password. This seemed a little weird as id just changed it.

I then thought id try logging in on Ubuntu ( using Chrome ) and was able to without any issue.

I then tried running my tests again and got the following:

...Request sent successfully. 
Request sent successfully. Starting Groovy-Eclipse compiler resolver.  Specified compiler level: unspecified 133 2.4.7.xx-201611170128-e46 = ACTIVE...

My tests were up and running.

It would appear that there was some issue with using my password on Ubuntu, so by resetting and logging into the Katalon site on Ubuntu resolved the issue. I haven’t tried running the tests on my Mac, so would be interesting to see whether this would cause any issues there.

Hopefully this will help anyone wanting to run tests on Ubuntu.

jason carney said:

I have just tried running the script on ubuntu and the tests ran!

I changed my password again on my Mac, where i was temporarily locked out ( i waited 5 - 10 minutes and able to log back in again ) - this happened right after i tried to log back in with my new password. This seemed a little weird as id just changed it.

I then thought id try logging in on Ubuntu ( using Chrome ) and was able to without any issue.

I then tried running my tests again and got the following:

...Request sent successfully. 

Request sent successfully. Starting Groovy-Eclipse compiler resolver. Specified compiler level: unspecified 133 2.4.7.xx-201611170128-e46 = ACTIVE…


My tests were up and running.  
  
It would appear that there was some issue with using my password on Ubuntu, so by resetting and logging into the Katalon site on Ubuntu resolved the issue. I haven't tried running the tests on my Mac, so would be interesting to see whether this would cause any issues there.  
  
Hopefully this will help anyone wanting to run tests on Ubuntu.  
  

  

Hi Jason,
Are you using Open JDK on Ubunutu? I just want to check if there is possibility of running Katalon on Ubuntu with Oracle JDK.
Thanks,
Kuldeep Rana

Hi Kuldeep

Im using Open JDK:

openjdk version "1.8.0_162"

It appears Oracle JDK isn’t recommended so im not sure thats causing any issues?