Errors exist in required projects

This is my first post so it might be a bit lengthy. I’ve been using katalon all day perfectly fine until I ran into this error trying to save a new object into /management console/data sources/add view/source config:

However when trying to save the object into /management console/data sources/add view/ it seems to work fine.
Here’s what it looks like after its been saved (looks normal):

however when I tried using said object in a test case I got error: object is null

Next in an attempt to fix everything I deleted the source config file and made a new one and resaved all my objects from scratch. No more errors trying to save

but now when I try to run ANY test case in my project I get this message:

picture of the referred file:

clicking proceed results in it instantly being flagged as done 0/1.

I’m currently stuck at this point not sure what to try next any help would be great.

Also I’ve shared the code with a coworker and they experienced the same initial problem trying to save into the source config folder. I assume my project is corrupted somehow?