Error when running tests in Docker with the Applitools plugin

Hi everyone,

I’ve decided to give the Applitools plugin a shot, and it works great in my tests when I run it locally with any browser. However, when I run these very same tests with Katalon Studio in Docker, the Applitools step in my test throws the following exception:

2019-06-28 14:00:17 - [TEST_CASE][ERROR] - Test Cases/User Interface/Login Page/Verify Login Page:     Test Cases/User Interface/Login Page/Verify Login Page FAILED.
java.lang.ClassNotFoundException: com.kms.katalon.keyword.applitools.BasicKeywords
at com.kms.katalon.core.main.CustomKeywordDelegatingMetaClass.getCustomKeywordClassAndSetMetaClass(
at com.kms.katalon.core.main.CustomKeywordDelegatingMetaClass.invokeStaticMethod(

Has anybody else managed to successfully run their Applitools tests in their Katalon Docker instance?
Thank you in advance!

error-stack-trace.txt (1.6 KB)

1 Like

Thank you for let us know. What was the Docker command used to execute the tests?

Hi, here’s the command I use:

docker run -t --rm -v /home/katalon/katalon-project/:/katalon/katalon/source katalonstudio/katalon -retry=0 -statusDelay=15 -executionProfile="staging" -testSuiteCollectionPath="Test Suites/Collections/StagingTests" -browserType="Chrome"

I think for some reason the Applitools plugin is not there (in the Docker instance of Katalon), hence the ClassNotFound exception. Is there a way I could check? The Katalon image is up to date.

1 Like

API key is needed to install plugins in CLI mode. Please refer to this post

1 Like

Thank you so much for pointing that out! It works like a charm now :grinning: