Error when pulling or fetching from Gitblit - Writing to secure store failed

When trying to fetch or pull from gitblit, I always have to reenter my username and password. How can that be stored and not have to reenter details.
And the Pull or push is complete, I get the following error message.
!ENTRY org.eclipse.egit.ui 4 0 2018-07-05 08:21:59.408
!MESSAGE Writing to secure store failed
!STACK 0
org.eclipse.equinox.security.storage.StorageException: No secure storage modules found.
 at org.eclipse.equinox.internal.security.storage.PasswordProviderSelector.findStorageModule(PasswordProviderSelector.java:190)
 at org.eclipse.equinox.internal.security.storage.SecurePreferencesRoot.getModulePassword(SecurePreferencesRoot.java:231)
 at org.eclipse.equinox.internal.security.storage.SecurePreferencesRoot.getPassword(SecurePreferencesRoot.java:224)
 at org.eclipse.equinox.internal.security.storage.SecurePreferences.put(SecurePreferences.java:224)
 at org.eclipse.equinox.internal.security.storage.SecurePreferencesWrapper.put(SecurePreferencesWrapper.java:110)
 at org.eclipse.egit.core.securestorage.EGitSecureStore.putCredentials(EGitSecureStore.java:58)
 at org.eclipse.egit.ui.internal.SecureStoreUtils.storeCredentials(SecureStoreUtils.java:35)
 at org.eclipse.egit.ui.internal.credentials.LoginService.login(LoginService.java:37)
 at org.eclipse.egit.ui.internal.credentials.EGitCredentialsProvider$2.run(EGitCredentialsProvider.java:229)
 at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
 at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
 at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
 at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
 at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
 at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
 at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
 at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
 at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
 at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
 at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
 at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
 at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
 at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
 at com.kms.katalon.core.application.Application.internalRunGUI(Application.java:115)
 at com.kms.katalon.core.application.Application.runGUI(Application.java:100)
 at com.kms.katalon.core.application.Application.start(Application.java:60)
 at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:498)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1519)


Please can someone help.

I faced the same problem, any thoughts?

Did you solve this problem? I have the same problem. Thanks