Error trying to run mobile tests on iOS 13.3

Hi, all,

I tried to run tests on an iOS 13.3 device (real device) and am getting a certificate error from the WebDriverAgent. I’ve already gone through the iOS device setup for Katalon and been able to successfully run these tests for months on several other devices with different iOS versions. I only see this error when trying against 13.3. I have changed nothing about the setup except plugging in a new device to my computer.

Has anyone else seen something similar or know the reason the entitlements would be invalid for only this version of iOS? I’m unclear why this would fail only for my 13.3 device but run successfully for all others.

Unable to start app at: '_<app location>_' (Root cause: org.openqa.selenium.SessionNotCreatedException: Unable to create a new remote session. Please check the server log for more details. Original error: An unknown server-side error occurred while processing the command. Original error: Unable to launch WebDriverAgent because of xcodebuild failure: xcodebuild failed with code 65
xcodebuild error message:

2019-12-17 16:26:42.169 xcodebuild[79538:26519486]  iPhoneConnect: 📱<DVTiOSDevice (0x7fd394fa6d10), _<iPod Name>_, iPod, 13.3 (17C5053a), 171d65dabae07dcfb35733cbabc410cbf2d301a0> installApplicationBundleAtPath:withOptions:andError:withCallback: failed with {
NSLocalizedDescription = "Unable to install \"WebDriverAgentRunner-Runner\"";
NSUnderlyingError = "Error Domain=com.apple.dtdevicekit Code=-402620394 \"The executable was signed with invalid entitlements.\" UserInfo={NSLocalizedFailureReason=The entitlements specified in your application\U2019s Code Signing Entitlements file are invalid, not permitted, or do not match those specified in your provisioning profile. (0xE8008016)., com.apple.dtdevicekit.stacktrace=(\n\t0   DTDeviceKitBase                     0x0000000111f676e7 DTDKCreateNSError + 109\n\t1   DTDeviceKitBase                     0x0000000111f67de9 DTDK_AMDErrorToNSError + 792\n\t2   DTDeviceKitBase                     0x0000000111fa756a __90-[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:]_block_invoke + 164\n\t3   DVTFoundation                       0x00000001021cf156 DVTInvokeWithStrongOwnership + 73\n\t4   DTDeviceKitBase                     0x0000000111fa7301 -[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:] + 1589\n\t5   IDEiOSSupportCore                   0x0000000111b88a25 __118-[DVTiOSDevice(DVTiPhoneApplicationInstallation) processAppInstallSet:appUninstallSet:installOptions:completionBlock:]_block_invoke.352 + 4523\n\t6   DVTFoundation                       0x00000001023003ba __DVT_CALLING_CLIENT_BLOCK__ + 7\n\t7   DVTFoundation                       0x0000000102301a92 __DVTDispatchAsync_block_invoke + 809\n\t8   libdispatch.dylib                   0x00007fff7bc965f8 _dispatch_call_block_and_release + 12\n\t9   libdispatch.dylib                   0x00007fff7bc9763d _dispatch_client_callout + 8\n\t10  libdispatch.dylib                   0x00007fff7bc9d8e0 _dispatch_lane_serial_drain + 602\n\t11  libdispatch.dylib                   0x00007fff7bc9e396 _dispatch_lane_invoke + 385\n\t12  libdispatch.dylib                   0x00007fff7bca66ed _dispatch_workloop_worker_thread + 598\n\t13  libsystem_pthread.dylib             0x00007fff7bed7611 _pthread_wqthread + 421\n\t14  libsystem_pthread.dylib             0x00007fff7bed73fd start_wqthread + 13\n), DVTRadarComponentKey=487927, NSLocalizedDescription=The executable was signed with invalid entitlements.}";
}

Thanks in advance for your help.

Katalon Studio 7.0.8
Appium: 1.15.1

Hi @SC_Smith,

This error means you have not built the WebDriverAgentRunner-Runner yet. Please follow this document to build WebDriverAgentRunner: https://docs.katalon.com/katalon-studio/docs/installing-webdriveragent-for-ios-devices.html.

This step needs to perform every time you change the Appium version.

Hi @duyluong,

Thanks for your reply. I have tried rebuilding the WebDriverAgentRunner-Runner in Xcode on the 13.3 device but it shows a certificate error that does not occur for the other devices with lower iOS version. Are you able to successfully build the WebDriverAgentRunner on an iOS device running 13.3? I’m curious if something has changed in the iOS version that is causing the build to error.

When I build on a device 13.0 and below, it’s successful, and so are Katalon tests. When I try to build on the 13.3 device, I see this error in Xcode:

Revoke certificate
Your account already has a signing certificate for this machine but it is not present in your keychain. To create a new one, you must first revoke the existing certificate.

Thanks.

This is an issue that relates with Account configuration in XCode. Please follow this discussion to resolve it:

Thanks for the information @duyluong. It looks like this was somehow specific to one device; I was able to run successfully on another iOS 13.3 device.

1 Like