Error message when Import from OpenAPI 3

With KSE 7.9.1, when i want to import an openAPI 3 json file, operation failed with this message error “Failed to import Rest services from openAPI” .

Have you got an idea to resolve this error, or is there a log file to have more informations ?

Hi @e.magon,

Please share some screenshots of your error. For the error log file, please click on the Help -> Error Log menu then share it here with us.

Thanks

Thank you for your help, but log isn’t explicit :
com.kms.katalon.composer.webservice.openapi.OpenApiImporter.parseJsonValue(OpenApiImporter.java:299)
The json file is verified with https://apitools.dev/swagger-parser/online/
How can I get the value error parsed ?

Hi @e.magon,

Can you share the JSON file with us in private chat?

Hi, i’m new in chat !

Here is the json file

openapi.zip (13.0 KB)

Hi @e.magon,

There was an issue of Katalon Studio when importing your open API 3 file in v7.9.1. We already fixed it in v8.0.0 that will release in the near feature. You can also try the pre-release version that’s available at this link: https://github.com/katalon-studio/katalon-studio/releases/tag/v8.0.0.rc3.

Note: When importing the file, there is a little bit hanging but please wait for a couple of seconds until Katalon Studio show all imported WebService requests because your API file is pretty large. We will improve this UX in the next version after v8.0.0.

Thanks

Hi,
Thanks for your quick response.

Emmanuel

Hi,

I am also trying to import OPEN API 3 file but getting same error in Katalon v8.0.5

Error Logs:

!MESSAGE
!STACK 0
java.lang.NullPointerException
at com.kms.katalon.composer.webservice.openapi.OpenApiImporter.parseJsonValue(OpenApiImporter.java:359)
at com.kms.katalon.composer.webservice.openapi.OpenApiImporter.parseJsonObject(OpenApiImporter.java:328)
at com.kms.katalon.composer.webservice.openapi.OpenApiImporter.parseJsonValue(OpenApiImporter.java:384)
at com.kms.katalon.composer.webservice.openapi.OpenApiImporter.parseRequest(OpenApiImporter.java:207)
at com.kms.katalon.composer.webservice.openapi.OpenApiImporter.parseRequests(OpenApiImporter.java:144)
at com.kms.katalon.composer.webservice.openapi.OpenApiImporter.importServices(OpenApiImporter.java:78)
at com.kms.katalon.composer.webservice.handlers.ImportOpenApiHandler.execute(ImportOpenApiHandler.java:75)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:58)
at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:319)
at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:253)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:173)
at org.eclipse.e4.ui.workbench.renderers.swt.DirectContributionItem.executeItem(DirectContributionItem.java:133)
at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:449)
at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.lambda$2(AbstractContributionItem.java:475)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4213)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1037)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4030)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3630)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1158)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1047)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:658)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:557)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:154)
at com.kms.katalon.core.application.WorkbenchApplicationStarter.start(WorkbenchApplicationStarter.java:23)
at com.kms.katalon.application.Application.runGUI(Application.java:191)
at com.kms.katalon.application.Application.start(Application.java:102)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
at org.eclipse.equinox.launcher.Main.run(Main.java:1447)

Any update on this?
Can anyone suggest something?

Please show the OpenApiImporter.java:359 and surrounding lines

These are Katalon internal files, not my project files. Where to locate this code, can you suggest?

@duyluong

Could you support @govind.sharma10 ?

@duyluong

Any update on this issue. I am using v8.1.0.

image

To reproduce this issue, kindly use the below links …

https://vocadb.net/swagger/index.html
https://vocadb.net/swagger/v1/swagger.json

https://petstore3.swagger.io/
https://petstore3.swagger.io/api/v3/openapi.json

@kazurayam

I have no idea.

Hi @discover.selenium,

I tried to reproduce the issue with your provided data on Katalon Studio 8.1.0 - macOS but it works fine. Are you using Windows?

Best regards,
Nam Nguyen.

Yes @nam.nguyen , I am using Windows 10 .

Thanks.

Hi @discover.selenium,

You can try with below steps to import, it works from my side:

  1. Go to https://vocadb.net/swagger/v1/swagger.json, copy all json data
  2. Go to https://editor.swagger.io/
  3. Paste your data has been copied here
  4. Accept convert to Yaml if need
  5. Export the file as .json or .yml file
  6. From the Katalon Tool, import the file from step#5
  7. Data is imported as below screenshot:

Hope it will be useful for you.

2 Likes

Thank You @loc.nguyen, your idea really worked. Appreicate your timely help.

Muchas Gracias Amigo :+1: