Elements not finding i Katalon 7.1.2 which was working in 6.2.1


I have snackbar messages to show success and validation messages while creating or editing an item. Im using same function to verify the message in create and edit pages. Which works fine in create page but doesn’t work in Edit page. It keeps showing element not found, but when we inspect and give the xpath in search, it shows the element in dom. All test cases are failing because of this

The wait for element present is the line of code where Katalon not finding the element. Te element is only visible for a few seconds to show the email already exists validation. it works fine when running for create an Item, but when editing the item, this is not finding by the katalon tool. But the element is there when we ctrl+f and search with xpath

Hi @akhillraam

Was the exact same script working on 6.2.1 and not 7.1.2 ? From the images I see slight changes (particularly in the steps preceding the problematic steps). Also, have you tried to add wait statements to eliminate the possibility of timing issues ?

Code is same. Im showing the Run result in console, It is the same function using twice in different pages. Elements and functionality are same. The action is to waitForElementVisible, and thats what fails.

I’m not seeing the same function (method) used twice. In the left screenshot (the suite) I’m seeing a Keyword addNewAgencyinEdit. In the right screenshot (a Test Case) I’m seeing a Keyword addRealtor.

In the TC (on the right) you appear to be waiting for an element to be removed from the DOM, but no indication that your screenshot has progressed to that point.

My advice to help us help you:

Ignore the suite. Focus on a Test Case. Show us the code up to the point of failure. Stop using “tree view” (deselect the tree-view icon) and post the linear log which is much easier to read:

I tried runnin it in test case, as mentioned im not showing the test case or keywords here…trying to show the Console where error is shown… forget about the keyword or testcase, that is different one. Error console is what im trying to show. Its the same function addAgency that im reusing in add realtor, and editAgencyDetails in different scenarios. The tthing is the WebUI waitforelementVisible for the validation message is not finding the element which is present in the dom.


Please post the relevant HTML structure of the element, the full console log and your test script. I still think that you need to execute the same script between 2 versions to really isolate it.

1 Like