Differences between chrome version on TSC

I run more than 10 test suit parallelly with firefox and chrome. Chrome version is differentiated between test suites. I want to run my test suite exact chrome version. My first opinion was firefox is causing the issue. When i execute firefox after chrome, chrome version was changed but i was wrong. It is changing randomly. It is blocking me to continue.1_TSC

@Ramazan

Are you executing locally ? Are you using any desired capabilities or any special set up ? Please provide the version of KS you are using.

No i dont use any special config. Just directly writing my scripts. i dont mention my chrome version on scripts. Also i can only chose one execution browser on TSC. I tried this on KRE and katalon studio on different versions. On KRE i tried 7.7.2.205 and 7.8.0.208 same error. On katalon studio i tried 7.7.0, 7.7.2 and 7.8.0 same error.

Just noticed one thing. This differentses always on same test suites. It doesnt matter on KRE or KS But on different chrome versions.
For example when i run my TSC on katalon studio, chrome version show 86.0 and 66.0 versions, on different computer it shows 86.0 and 87.0 version.

Also it show different versions on KRE. I think there is an internal chrome version caching that uses old version of chrome version.

But this is also awkward situation on KRE (inside docker image). Because according to official-docker-image-repo there should be only one chrome version. There shouldn’t be any other chrome version because chrome installed only once on docker image.

I checked desired capabilities on KS. I didnt make any special setup. It is on defaut configs.

Is there any update?