Delay in fill fields Katalon Studio 7.0.0 RC2

Hello everyone,

The system is delaying to fill the fields (30s).
This is happening since 6.3.4 version (I think)
I’m testing in Linux version (Debian)

Best Regards,

Anyone can help me?

Hi @jjunior

I tried SetText on some websites on 7.0.0 RC2 and it seems to set text within only a few seconds. Is there a demo I can work with ? Can your try older versions to see if this problem was introduced in the recent versions ?

Hi @ThanhTo,

In 6.3.2 version this works fine.
When I use command line to execute it goes fine (7.0.0 RC2).
This started in 6.3.4, 7.0.0 RC1 and 7.0.0 RC2…

Hello Russ

I don’t know if is compatibility or something like it…
I don’t have the Analytics in 7.0.0 (TestOps is disable). I opened the same project in 6.3.2 and Analytics is also disable.

Okay. It was worth a shot. I’ll delete my post.

I’m trying other tests and when I try to open google site, it goes normal, but when I try my system, it takes so long time…

I don’t know what is happening hehe.
I will continue using 6.3.2

Thank you for your time.

Well, it certainly sounds as though your system is the cause.

Does it behave normally when you test it by hand?


It goes normally testing by hand, testing in 6.3.2 version and testing by command line in 7.0.0 RC2 ^^

If you’re familiar with the Network Tab in DevTools, perhaps you could watch for slow activity in there. This assumes you have fields on your page that require backend/XHR support.

If that proves unhelpful, try clearing/cleaning your project.

In my case, I don’t know if KS is waiting 30 seconds and then execute the step (because the time is ever 30.xpto seconds, and when I execute in KS 6.3.2 is ever less than 1 second)

Try a dumb, stupid test to print the same thing 20 times. It should be done in a few seconds.

println "Work dammit"
println "Work dammit"
println "Work dammit"
println "Work dammit"
println "Work dammit"
// etc...

If that’s pretty quick, we may be looking at delay issues.

Also, I imagine @ThanhTo is going want to see your logs but I’m not sure we’re there yet.

The process to print is so fast, also to open browser.


I’m sure it’s not this, but JIC…

Did you clean your project yet?

Really is not it:

Yes, when I see an topic to delete some files, I tried but with no success…

I think @ThanhTo will need your log file:


I deleted the file and executed again…


What file?

The .log file