Content lenght = 0 , 404 Not found response

Hello Team,
I tried to test my API. I posted a JSON with many possibility of header and body settings/parameters, but I always got 404 Not found result OR content-lenght Error.
Can you recommend a solution, please. Thanks!

(1) I got valid auth token and the header was updated:

(2) I had 16 chars in body JSON

(3) Tried to post without content-lenght, but I got 404 Not found.

(4) here is the header with content lenght =16

(5) but I got error message, that Content length is : org.apache.http.ProtocolException: Content-Length header already present

(5) here is the Error message:
com.kms.katalon.core.webservice.exception.SendRequestException: org.apache.http.client.ClientProtocolException
at com.kms.katalon.core.webservice.common.HttpUtil.sendRequest(
at com.kms.katalon.core.webservice.common.BasicRequestor.send(
at com.kms.katalon.controller.WebServiceController.sendRequest(
at org.eclipse.jface.operation.ModalContext$
Caused by: org.apache.http.client.ClientProtocolException
at org.apache.http.impl.client.InternalHttpClient.doExecute(
at org.apache.http.impl.client.CloseableHttpClient.execute(
at com.kms.katalon.core.webservice.common.HttpUtil.sendRequest(
… 4 more
Caused by: org.apache.http.ProtocolException: Content-Length header already present
at org.apache.http.protocol.RequestContent.process(
at org.apache.http.protocol.ImmutableHttpProcessor.process(
at org.apache.http.impl.execchain.ProtocolExec.execute(
at org.apache.http.impl.execchain.RetryExec.execute(
at org.apache.http.impl.execchain.RedirectExec.execute(
at org.apache.http.impl.client.InternalHttpClient.doExecute(
… 6 more

Well, finally I found the solution.
I set the header parameters like this:

And the body was set to:

After that I got 200 OK.