Console Mode Execution

Great! I figured it out also this morning. I do not use a GUI version of Katalon, so this initially was lost to me, plugins were no use to me I thought. I ‘installed’ the Basic Report plugin and generated an API key from my account, which I added as flag -apiKey= to the command line command and that worked out of the box. I’m very happy with this functionality :blush:

Problem for me is that I don’t get to through the Proxy when trying to “reinstall” the PlugIn.

Is there any way to prevent that the CLI re-installs the Plugin

@erik.moderegger, used the api key as below in command and ran the tests but am not seeing the html basic report generated as earlier. I see only execution* log files.

docker run -t --rm -v “$(pwd)”:/katalon/katalon/source katalonstudio/katalon katalon-execute.sh -browserType=“Chrome” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/ST1” -gURL=URL -apikey=XXXXX-XXXXX-XXXXX-XXXX-XXXX

Am running these tests on a katalon docker container.

Hello,

Here’s my generated property file:

#Fri Jun 28 16:16:22 CST 2019
projectPath=C\:\\Users\\Admin\\git\\testscripts\\SampleProject.prj
retry=0
testSuiteCollectionPath=Test Suites/RMS/RMS_TSC
apiKey=5beb57ba-6f7a-4897-bae6-970f4313cc14

When I try to run it in CLI:

katalon -propertiesFile=“C:\Users\Admin\git\testscripts\console.properties” -noSplash -runMode=console -consoleLog -noExit --config -webui.autoUpdateDrivers=true

This is what I get:

Katalon workspace folder is set to default location: C:\Tools\Katalon_Studio_Windows_64-6.1.2\config
!SESSION 2019-06-28 16:46:37.000 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_181
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -propertiesFile=C:\Users\Admin\git\testscripts\console.properties -runMode=console --config -webui.autoUpdateDrivers=true
Command-line arguments: -os win32 -ws win32 -arch x86_64 -data @noDefault -propertiesFile=C:\Users\Admin\git\testscripts\console.properties -runMode=console -consoleLog --config -webui.autoUpdateDrivers=true

!ENTRY org.eclipse.core.resources 2 10035 2019-06-28 16:46:38.729
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
Starting Groovy-Eclipse compiler resolver. Specified compiler level: unspecified
170 2.4.7.xx-201611170128-e46 = ACTIVE

INFO: Katalon Version: 6.2.0
INFO: Command-line arguments: -propertiesFile=C:\Users\Admin\git\testscripts\console.properties -runMode=console --config -webui.autoUpdateDrivers=true
INFO: User working dir: C:\Tools\Katalon_Studio_Windows_64-6.1.2
INFO: User home: C:\Users\Admin
INFO: Java vendor: Oracle Corporation
INFO: Java version: 1.8.0_181
INFO: Local OS: Windows 10 64bit
INFO: CPU load: 43%
INFO: Total memory: 16266 MB
INFO: Free memory: 7642 MB

Missing required argument(s): projectPath.
16:46:40.094 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe [git, --version],C:\Program Files\Git\cmd
16:46:40.133 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe may return ‘git version 2.21.0.windows.1’
16:46:40.133 [Worker-0] DEBUG org.eclipse.jgit.util.FS - remaining output:

16:46:40.139 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe [git, config, --system, --edit],C:\Program Files\Git\cmd
16:46:40.202 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe may return ‘C:/Program Files/Git/mingw64/etc/gitconfig’
16:46:40.202 [Worker-0] DEBUG org.eclipse.jgit.util.FS - remaining output:

projectPath is there but it says it is missing. Thanks in advance!

How to do this?

@agarcia : I guess this bug has still not being fixed. I am using Katalon v6.1.5 and facing this issue. What version are you using?
But there is a workaround as mentioned in this post: projectPath argument missing when running from a properties file

Hi @BlueSapphire
Thank you. I’m using 6.2.0 :slight_smile:

Hello to everyone,
I am a macOS user and I note that the auto generated command line contains -noExit that is mentioned as a Window -Only option. Its presence make us having to hard stop the script execution with control + c. I don’t what it does on linux. Is it very important, we could erase it manually in the command line before to execute it, but is it possible to don’t generate it when we’re using a different os?

not sure about how to set it depending on the OS but yea, you should be able to remove that line without it really affecting your test execution. I believe its meant to allow the tester to review the log post execution

Will the console mode be available for mobile testing? I have a mobile app and I would need to execute the test suite automatically when there is changes in the backend of our system…

Hi All! I need to set number of times running test cases in the test suite. And i use for these -retry option, here my command:
katalon -noSplash -runMode=console -projectPath=“path” -statusDelay=5 -retry=4 -testSuitePath=“Test Suites/demo” -executionProfile=“default” -browserType=“Chrome”
And id doesn’t work, test suite run only one time, could you please help me with it?

Hello,
is there a way to generate a collection suite command and to set the “Max concurrent instances” field as in Katalon UI ?
image

Indeed, when generating CMD, I only got this command :
katalon -noSplash -runMode=console -consoleLog -noExit -projectPath="C:\dev\Katalon Studio\reflexfmtests\ReflexFmTests\ReflexFmTests.prj" -retry=0 -testSuiteCollectionPath="Test Suites/cAllTests"

In fact, I finally understood that concurrent instances has to be set in collection and it is saved in file collection.ts
So we have no need to have a parameter in command line to set it. :stuck_out_tongue_winking_eye:

1 Like

Hi everyone.

Is there a way to send the test result to slack using command line?

Many thanks

Is there are any way to runMode = UI mode…?

I think you would just remove -noSplash

Hello,

Any one know where –info -buildLabel=“text” -buildURL=“text” these inforrmation will be used ?
at analytics ?

This to correlate execution details at analytics and test execution from your CI tool

Hi @musaffir.puthukudi

The information about the build displayed in Executions Table in Katalon Analytics.

Jass

Hi Team,

Katalon version:7.0.6

Is it possible to run the mobile application through the cmd line. I generated the command from console mode and tried to add it in the cmd prompt.
I am getting an error message as: ‘katalonc’ is not recognized as an internal or external command,
operable program or batch file.