Console Mode Execution

Hi Team,

I am executing a Test suite in the command line mode. The Test suite is executing correctly through the command line mode. However, i am unable to send the email. The email works fine when the Test suite is executed from the Katalon IDE. Here is the command;

/Applications/Katalon\ Studio.app/Contents/MacOS/katalon --args -noSplash -runMode=console -consoleLog -noExit -projectPath="/Users/namigupt/Desktop/work/codebase/2019/Q1/unity/BDD/project-x/project-x.prj" -retry=0 -testSuitePath="Test Suites/X" -executionProfile="default" -browserType="Web Service" -sendEmail="XXXX@XXX.XXX"

Can you please help me in fixing this issue?

Regards,
Namit

Try configuring email , in project settings instead of using it command itself.

hi,I’m running the script on the command line,But the message cannot be sent successfully.The script is as follows:
“./Katalon\ Studio.app/Contents/MacOS/katalon --args -noSplash -runMode=console -consoleLog -projectPath=”/Users/xxxxxx/workspace/xxxxxx/wg.prj" -retry=0 -testSuitePath=“Test Suites/Login/Login” -executionProfile=“stg(private)” -browserType=“Chrome (headless)” -sendMail="xxxx@xxxxxxx.com"
"

It would have been nice, if we could set the mail server settings via console. Also why not make the subject line dynamic - It should show the whether it failed and passed in the subject line.?

Hello together,

I’m trying to execute katalon-cli behind corporate proxy as following
./katalon -noSplash -runMode=console -projectPath="/opt/katalon/katalon-tests.prj" -reportFolder="/opt/katalon/reports" -reportFileName=index -retry=0 -testSuitePath=“Test Suites/Test Suite” -executionProfile=“Default” -browserType=“Firefox” -apiKey="" --config -proxy.option=USE_SYSTEM

I booked a plugin “Basic Report” in katalon.store and set environment variables:

  • HTTP_PROXY=corporate-proxy:3128
  • HTTPS_PROXY=corporate-proxy:3128

and got exception:
Caused by: java.net.UnknownHostException: store.katalon.com: Name or service not known
at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method)
at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:929)
at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1324)
at java.net.InetAddress.getAllByName0(InetAddress.java:1277)
at java.net.InetAddress.getAllByName(InetAddress.java:1193)
at java.net.InetAddress.getAllByName(InetAddress.java:1127)
at org.apache.http.impl.conn.SystemDefaultDnsResolver.resolve(SystemDefaultDnsResolver.java:45)
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:111)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:353)
at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:380)
at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:236)
at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:184)
at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:88)
at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:110)
at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:184)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:107)
at com.kms.katalon.plugin.service.KStoreRestClient.executeGetRequest(KStoreRestClient.java:256)
at com.kms.katalon.plugin.service.KStoreRestClient.getLatestPlugins(KStoreRestClient.java:58)

Then I tried with MANUAL_CONFIGURATION like:
–config -proxy.option=MANUAL_CONFIG -proxy.server.type=HTTP -proxy.server.address=“corporate-proxy” -proxy.server.port=“3128”

and got the same exception.

Do You have any best practises how to configure Katalon behind a proxy to download plugins from Katalon Store?

Thanks

I was trying also this approach to call it from pipeline:

withEnv(['HTTP_PROXY=http://proxyAddress:port']) {
sh "npm run test"
}

Seems to be it is not able to get proxy settings, it works only if you set proxy in katalon UI, but this is not suitable for pipeline jenkins, cause it does not catch this settings. It works only if you are logged into terminal and run it.

I want to use Analytics, but it not send to it
I see that it not enabled when start the program
I start tests by Jenkins console command
There I see rows about sending to analytics but when i go to it no luck
And when i start programm on virtual machine i see that in project this option not enabled

Hi,

After generating the console properties and executing the below commands in the command prompt, it doesn’t run anything.

katalon -propertiesFile="<C:\Users\kowsalra\Katalon Studio\Appa Thunai\console.properties>" -runMode=console

katalon -propertiesFile="<C:\Users\kowsalra\Katalon Studio\Project\console.properties>" -runMode=console -browserType=Chrome

Can anyone help me to sort out this?

hello team.
i have question for cmd mode.
when i use cmd mode, i cant save my report file as html…
without cmd mode, it works very well. but when i use cmd mode,
it cant be saved as html files
plz reply asap^^
thanks

Even for me i see this observation.

  1. With Katalon studio GUI tool, if i run tests it generated only execution* files and not the html reports. Manually i need to run a free plugin to export in html format.

  2. Most important, for me is running this in command line.
    Wheneven i run in command line more, i see same issue. Seeing only execution* files and not html reports.

Please suggest a solution asap.

Thanks.

@silee, @raj and all others,
Same challenge for me, I would like to generate Junit or other format test results from cli commands. Going to the GUI is not an option for me, as my work is parts of a CI pipeline (Ubuntu agent) that doesn’t handle manual steps at all. Some ideas or trick would be very welcome.

for the ‘propertiesFile-glag-not-working’, I’ve written a bug report. Glad to provide more logs there, if needed.

Kind regards,

Ludo

@silee, @raj and @LudoNieuw
You need to add your Api-Key (acc. to the docs).
The problem for me is that it then starts “reloading plugins” but this takes forever.

1 Like

Great! I figured it out also this morning. I do not use a GUI version of Katalon, so this initially was lost to me, plugins were no use to me I thought. I ‘installed’ the Basic Report plugin and generated an API key from my account, which I added as flag -apiKey= to the command line command and that worked out of the box. I’m very happy with this functionality :blush:

Problem for me is that I don’t get to through the Proxy when trying to “reinstall” the PlugIn.

Is there any way to prevent that the CLI re-installs the Plugin

@erik.moderegger, used the api key as below in command and ran the tests but am not seeing the html basic report generated as earlier. I see only execution* log files.

docker run -t --rm -v “$(pwd)”:/katalon/katalon/source katalonstudio/katalon katalon-execute.sh -browserType=“Chrome” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/ST1” -gURL=URL -apikey=XXXXX-XXXXX-XXXXX-XXXX-XXXX

Am running these tests on a katalon docker container.

Hello,

Here’s my generated property file:

#Fri Jun 28 16:16:22 CST 2019
projectPath=C\:\\Users\\Admin\\git\\testscripts\\SampleProject.prj
retry=0
testSuiteCollectionPath=Test Suites/RMS/RMS_TSC
apiKey=5beb57ba-6f7a-4897-bae6-970f4313cc14

When I try to run it in CLI:

katalon -propertiesFile=“C:\Users\Admin\git\testscripts\console.properties” -noSplash -runMode=console -consoleLog -noExit --config -webui.autoUpdateDrivers=true

This is what I get:

Katalon workspace folder is set to default location: C:\Tools\Katalon_Studio_Windows_64-6.1.2\config
!SESSION 2019-06-28 16:46:37.000 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_181
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -propertiesFile=C:\Users\Admin\git\testscripts\console.properties -runMode=console --config -webui.autoUpdateDrivers=true
Command-line arguments: -os win32 -ws win32 -arch x86_64 -data @noDefault -propertiesFile=C:\Users\Admin\git\testscripts\console.properties -runMode=console -consoleLog --config -webui.autoUpdateDrivers=true

!ENTRY org.eclipse.core.resources 2 10035 2019-06-28 16:46:38.729
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
Starting Groovy-Eclipse compiler resolver. Specified compiler level: unspecified
170 2.4.7.xx-201611170128-e46 = ACTIVE

INFO: Katalon Version: 6.2.0
INFO: Command-line arguments: -propertiesFile=C:\Users\Admin\git\testscripts\console.properties -runMode=console --config -webui.autoUpdateDrivers=true
INFO: User working dir: C:\Tools\Katalon_Studio_Windows_64-6.1.2
INFO: User home: C:\Users\Admin
INFO: Java vendor: Oracle Corporation
INFO: Java version: 1.8.0_181
INFO: Local OS: Windows 10 64bit
INFO: CPU load: 43%
INFO: Total memory: 16266 MB
INFO: Free memory: 7642 MB

Missing required argument(s): projectPath.
16:46:40.094 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe [git, --version],C:\Program Files\Git\cmd
16:46:40.133 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe may return ‘git version 2.21.0.windows.1’
16:46:40.133 [Worker-0] DEBUG org.eclipse.jgit.util.FS - remaining output:

16:46:40.139 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe [git, config, --system, --edit],C:\Program Files\Git\cmd
16:46:40.202 [Worker-0] DEBUG org.eclipse.jgit.util.FS - readpipe may return ‘C:/Program Files/Git/mingw64/etc/gitconfig’
16:46:40.202 [Worker-0] DEBUG org.eclipse.jgit.util.FS - remaining output:

projectPath is there but it says it is missing. Thanks in advance!

How to do this?

@agarcia : I guess this bug has still not being fixed. I am using Katalon v6.1.5 and facing this issue. What version are you using?
But there is a workaround as mentioned in this post: projectPath argument missing when running from a properties file

Hi @BlueSapphire
Thank you. I’m using 6.2.0 :slight_smile:

Hello to everyone,
I am a macOS user and I note that the auto generated command line contains -noExit that is mentioned as a Window -Only option. Its presence make us having to hard stop the script execution with control + c. I don’t what it does on linux. Is it very important, we could erase it manually in the command line before to execute it, but is it possible to don’t generate it when we’re using a different os?