Connecting Katalon to Sauce labs via tunnel


Based on the documentation I’ve been able to connect to Sauce labs, but for testing my sites, I need to use a Sauce connect tunnel, and can’t seem to setup in Katalon correctly. Can someone help me with this.

Seems like unless I get the setting correct to set the tunnel name and then connect to the tunnel, my test won’t work

Hi @Michael_Grater

Can you show us what have you tried ? Setting up the Sauce Connect Proxy is quiet a complicated process so it’s difficult to diagnose what went wrong in your set up without more details. Have you tried to download the Sauce Connect in Sauce Labs’ official documentation and see their FAQs ?

Cheers !


Sorry it’s taken a bit. I’ll attach some screenshots

  1. I have configured the Desired capabilities section to connect to my tunnel.
  2. I am able to launch the test and connect to the browser, but when the test attempts to connect to the website, I get a “Can’t connect securely to this page” message and refers to outdated or unsafe TLS security settings. Attached are screenshots of the Katalon studio configuration as well as screenshots of the tunnel being active and the session in sauce labs

Quick update

  1. After connecting with the Sauce labs tunnel, the screenshots that I sent above was happening consistently always
  2. Our QA and Staging environment are restricted by IP, so I did a few things
    A. Attempted to access our QA environment via Katalon automation with a secure tunnel turned on
    B. Attempted to access our QA environment via Manual testing with a secure tunnel turned on
    In both cases, I receive the “unsafe TLS security settings” message
  3. I then pointed my test to the production environment, which is not restricted by IP, and was able to successfully execute tests on all browsers using the Sauce labs settings in Katalon without issue
    After doing that test, I then went back to Katalon and created a new configuration that utilized the tunnel, which I’ll include in a new screenshot, and attempted to run the test against IE again, and received another error
  4. I then tried a different browser and using the tunnel, I was able to manually access the QA environment in firefox and IE11 (not with the automation)
  5. Then attempted to access the tunnel in Firefox via automation, and received the same error
    attached are what my Katalon configuration settings look like for the tunnel
    Just appears that the test is not connecting with tunnel correctly

@ThanhTo- I’ve been working with Sauce labs for the last week on the issue, and I believe I’ve taken it as far as I can on their end, and this is a significant blocker for me to get full cross browser testing working correctly via Katalon. I will provide you a bit more information in the hopes that you can help me out here.

  1. Attached is my settings for Sauce connect in Katalon studio. I’ve updated as per Sauce labs. I’ve attempted to change the sauce connect Port from 80 to 443 and this leads to the connection not working at all in Sauce
  2. The issue only occurs when I attempt to use the secure tunnel to access our QA environment
  3. I’ve run logs on Sauce tunnel to see if it was an issue on Sauce, but since Sauce does work with your plug in when I log into our production environment, it appears to be an issue with connecting to the secure tunnel
    A. When I connect to Sauce via Port 80 - I am able to open a Sauce labs VM, but can not access the secure site

    B. When I connect to Sauce via Port 443, I receive an error in Katalon and I’m not able to access a VM at all

Attached is the tunnel log from Sauce labs.
tunnel_log.txt (565.6 KB)

Please advise. This is blocking me from moving any further in getting cross browser testing working.

Thank you,


1 Like

Just pulled the log from Katalon as well for a test run. Attaching here.
katalon.log (38.2 KB)

Thank you @Michael_Grater

Our development team is looking into this issue, we will be taking into account new information. I’ll definitely keep you up to date.

Cheers !

@ThanhTo- is there any update on this issue?

Hi @Michael_Grater

Sorry for the delayed, our team hasn’t made any progress on this either. We are still looking into it. Apologize for the inconvenience.


Even I too facing same issue… Is there any solution to fix it to use Sauce Lab using Katalon via Tunnel configuration…

Hi Team,

Could you please help me out to fix this issue.

i hope some people do realize that 443 is the port for https, not for http. just saying …

HI Team,
I have created the custom fields for Mobile and Desktop. If I ran for Mobile for Tunnel Settings and it is working fine. But while i am using with Desktop using chrome browser, able to run the jobs but private URL’s is not accessible. it showing site can’t be reached.Other browsers like Firefox and IE are working fine. Only issue with the chrome browser. Could you please suggest any additional configuration need to be setup for chrome browser?

Hi, I am also facing the same issue, and this is a blocker for me to proceed further, please help is suggesting the fix.