Command line for KR

I get an error when using the Command line for KR in Powershell on Windows 10 :

PS C:\kata> kr-cli run chrome C:\kata\Parrainages.krecorder --report=C:\kata
1.1.0

[ERROR] Error message: The path is not valid. Please try again!

Hi,

As you are executing a test suite with this command line: kr-cli run <browser> <pathToHtmlFile> --report <pathToReportFolder>, please double check either pathToHtmlFile or pathToReportFolder whether they are correct or not. I am not sure that --report= should be replaced by --report or not but try. Refer to this document for more: GitHub - katalon-studio/kr-cli: A public repo for Katalon Recorder Command-Line Runner

Thanks for your help, but I always get the “Error message: The path is not valid. Please try again!”

I tried removing the =

It seems like your C:\kata\Parrainages.krecorder or C:\kata 1.1.0 are incorrect. Can you please navigate to kata folder and send me screenshot?

Sorry for the delay, here is the screenshot of my kata folder

The folder and test suite names are the same, what could be the problem ?
kr error

Hi,

Did you get the solution from your problem ? I’ve the same issue.

I’ve take a look in the code to check what’s wrong, it looks like the conditions at lines 73, 76 and 79 are logging the error message, but I don’t understand why and where in these conditions make the command line fail.

NB : In the online documentation the --report option assume the = is required but in the github documentation the --report option assume it doesn’t require the =. I think that an update will avoid this misunderstanding.

NB 2 : In both online documentation and github documentation, we need to input a pathToHtmlFile, but if I do, I get the error on the following screenshot. Maybe an update to pathToKrecorderFile will avoid the misunderstanding.

The error you’re encountering with the KR command line in PowerShell on Windows 10 suggests a problem with the provided file path. Ensure the path to your Parrainages.krecorder file is accurate, check for spaces and use double quotation marks if needed. Verify backslashes as path separators and ensure proper permissions for the PowerShell session. A corrected example might be kr-cli run chrome “C:\kata\Parrainages.krecorder” --report=“C:\kata”. If issues persist, additional details about the file structure could aid in troubleshooting.

Hi,

Well, I looked again in the code and found that at line 21 the file must be with an html extension and his content must be as a kr format. So, when you download a .krecorder file, you must change his extension to .html and point to that file in the kr-cli command :

kr-cli run chrome "C:\tests\loginage.html" --report "C:\test\kr-test"

Now, it looks like it’s working but I get a new error that I don’t understand, can you help please ?

NB : When I run the command I don’t get any file in the report folder.