com.kms.katalon.execution.core.exceptions.ExecutionException: com.kms.katalon.execution.core.exceptions.ExecutionException: No mobile device with name 'A64566A3-B48D-42E4-83EC-F10536249AE1' available

Getting the above issue , while running the below command even though devices are available on Mac OS
sudo ./katalonc -noSplash -runMode=console -projectPath=“/Users/jenkins/Desktop/project folder.prj” -retry=0 -testSuitePath=“Test Suites/iOSSuites/iOS_EndtoEnd_RegressionRun” -browserType=“iOS” -deviceId=“A64566A3-B48D-42E4-83EC-F10536249AE1” -executionProfile=“Dev” -apiKey=“id provided” -orgID=13444 -appiumDirectory=“/usr/local/lib/node_modules/appium”

1 Like

Hi there,

Thank you very much for your topic. Please note that it may take a little while before a member of our community or from Katalon team responds to you.

Thanks!

Team ,PLease help me , am facing this issue since last month , tried lot of the things and did not work

Hi @balamaddaiah.kuruva ,

From my side, I have tried using sudo at the start of the command line and it throws the same error for me. But after I remove sudo the test runs successfully and the iOS simulator is recognized.

Therefore, could you please try removing the sudo from the command line arguments and then run the tests again? If you do not have root/admin permissions on the Mac machine, then I would strongly suggest to acquire those permissions as this will help KRE to connect and access Xcode devices.

Thank you

Thanks bhavynash, I removed and tried still getting the permission issue and we are using jenkins user and having full admin access for this user

The issue was resolved after following the below steps:

  • Removing all the duplicate node folders from the test machine, and
  • Setting the correct node path in the .zprofile file

@balamaddaiah.kuruva, I would be happy to have your confirmation on the above?

Thanks