CMD doesn't work the same as Manual Run

When I first install Katalon, I have to configure the proxy to activate the product. But, I have to revert it back to use system proxy settings to access URL sites ( or it’ll linger and lose connection). The weird thing is that when I run katalon manually with the “RUN” button, it works perfectly fine. I’ll build the CMD line and execute it, and it’ll open katalon, open the browser, go to the URL, but it’ll linger and break ( just like if you’d leave the proxy preference setting on the manual setting, there will be rare times where i’ll have to revert it back to “use system proxy” which I assumed it’ll save". I don’t know what could be the cause of this. Do I need to add a line in the CMD line to make sure the proxy setting is to use the system configuration?Help?

Hi rabah,

This is likely an issue from using proxy settings in console mode. I’ve logged a ticket for it and will inform you soon. If this is an issue, it will be fixed in next release.

Thanks a lot :slight_smile:
do you think about any temporary solution for this?
I’ve already tried to set the proxy directly in the groovy script, i also tried to set the proxy infos directly in the .properties file… nothing works
I’m desperate :’(

I have the same problem. The proxy setting is not working properly. I have to configure it on every time i start katalon. CMD execution is the same problem - proxy settings are not available.

@Matthias Rauh said:
I have the same problem. The proxy setting is not working properly. I have to configure it on every time i start katalon. CMD execution is the same problem - proxy settings are not available.

Proxy settings is currently an issue when it’s used in console mode execution. It will be fixed in the next release as soon as possible.