Chrome Driver, unable to navigate


#1

Hi,
Was executing Katalon with the Chrome all this while. However, I hit the error that the Chrome did not Navigate to the URL after the browser is launched today. Hitting the error Chrome not reachable error.
**Recording of the step is working fine. The problem happen @ Executing with Chrome only. Found some other’s post on the similar problem, have tried some suggestion:
Have tried to reboot the machine > Not work
Have tried to replace the Chrome Web Driver > Not work
Have tried to delete chrome user profiles > Not work

Have tried to launch the browser via custom keyword (changing :
DriverFactory.changeWebDriver(driver) ) > it’s works.
My doubt is, I am still pointing to the same Default WebDriver in Katalon configuration & without changing any of the other property, what is this different from the default OpenBrowser keyword?

The custom keyword method will always force me to use the Chrome Driver, which is not the solution that I intended to use. I would like to make the script to accept any browser dynamically .Eg. similar to the WebUI.OpenBrowser(’’) , that can accept all driver based on user selection.

Is there any way that I can detect what browser options the user is selecting from runtime?


#2

The error showed in the console:

Starting ChromeDriver 2.35.528161 (5b82f2d2aae0ca24b877009200ced9065a772e73) on port 47690

Only local connections are allowed.

11-04-2018 05:53:51 AM - [FAILED] - Unable to open browser with url: ‘’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited normally

(Driver info: chromedriver=2.35.528161 (5b82f2d2aae0ca24b877009200ced9065a772e73),platform=Windows NT 6.1.7601 SP1 x86_64) (WARNING: The server did not provide any stacktrace information)

Command duration or timeout: 62.03 seconds


#3

My doubt is, I am still pointing to the same Default WebDriver in Katalon configuration & without changing any of the other property, what is this different from the default OpenBrowser keyword?

By DriverFactory#getChromeDriverPath(), you can see which path of ChromeDriver is used when you call WebUI.openBrowser(). Have a look at the following post:


#4

You can let ChromeDriver to write chromedriver.log file. You would find more information in it. See the following post


#5

I hit the error that the Chrome did not Navigate to the URL after the browser is launched today.

You were happy yesterday and not today? What sort of change occurred for you today? Is it the case that your Chrome browser is auto-upgraded to newer version?


#6

Yes, was happy yesterday. In my machine, Chrome browser did not auto update.
Only changes I made today was to Add an External Libraries, but I have also removed that Jar file already.
Same problem occur with all the projects.


#7

Let me confirm one thing. You got this message:

Chrome failed to start: exited normally

Not the following one?

Chrome failed to start: exited abnormally


#8

Are you working on Windows? Mac? Linux?

Are you having problem in Katalon GUI or Console Mode?


#9

Yes. That is the exact error message:
1-04-2018 05:53:51 AM - [FAILED] - Unable to open browser with url: ‘’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: **exited normally
**


#10

Please try to take chromedriver.log. I think you would find something useful in it.


#11

Launching chrome: “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” --chrome.switches --disable-background-networking --disable-client-side-phishing-detection --disable-default-apps –disable-extensions --disable-extensions-except=“C:\Users\MAKATALON\AppData\Local\Temp\scoped_dir4100_18859\internal” --disable-hang-monitor --disable-popup-blocking --disable-prompt-on-repost --disable-sync --disable-web-resources --enable-automation --enable-logging --force-fieldtrials=SiteIsolationExtensions/Control --ignore-certificate-errors --log-level=0 --metrics-recording-only --no-first-run --password-store=basic --remote-debugging-port=12460 --test-type=webdriver --use-mock-keychain --user-data-dir=“C:\Users\MAKATALON\AppData\Local\Temp\scoped_dir4100_6377” data:,

[1541288484.579][INFO]: RESPONSE InitSession unknown error: Chrome failed to start: exited normally

In the working custom keyword version:

[1541287492.432][INFO]: Launching chrome: “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” --disable-background-networking --disable-client-side-phishing-detection --disable-default-apps --disable-hang-monitor --disable-popup-blocking --disable-prompt-on-repost --disable-sync --disable-web-resources --enable-automation --enable-logging --force-fieldtrials=SiteIsolationExtensions/Control --ignore-certificate-errors --load-extension=“C:\Users\MAKATALON\AppData\Local\Temp\scoped_dir10472_25959\internal” --log-level=0 --metrics-recording-only --no-first-run --password-store=basic --remote-debugging-port=12396 --test-type=webdriver --use-mock-keychain --user-data-dir=“C:\Users\MAKATALON\AppData\Local\Temp\scoped_dir10472_15799” data:,

[1541287493.301][INFO]: resolved localhost to ["::1",“127.0.0.1”]

Looks like the disable-extensions is the culprit , but I did not hit any problem before Today. :frowning:


#12

Looks like the disable-extensions is the culprit

See the following post of mine:

Did you add any Chrome plug-in which is setup to be “unable to disable” for users?

----------

but I did not hit any problem before Today.

Yes, Katalon Studio’s WebUI.openBrowser() opens Chome with disable-extensions option. It did so, and will do so. Therefore, I doubt it, disable-extensions to be the cause of your change today.


#13

MaKatalon,

Only changes I made today was to Add an External Libraries,

Did you add an extension to Chrome? or to Katalon Studio?


#14

No new extension added. The Katalon recorder extension was there even before the problem occured.


#15

MaKatalon,

I have business today. I can not follow this topic any more. sorry.


#16

Hi @4280-kazurayam
I found an extension which was added by policy, which I can’t disable it. (Not sure if that extension was already there before the problem though…) but I guess you are right, the issue most probably due to the disable-extension that I can’t disable it.

Looks like I have to use customKeyword to open the browser if the browser is Chrome then. TQVM for your help :slight_smile:


#17

No problem @4280-kazurayam
You have been a great help .