Can't Open Browser with Chrome Driver ver.76

ok, thanks. it’s work :slight_smile:

Hi,

I was able to run it perfectly fine yesterday and when I tried to run it today, I encountered the same issue. Will try this solution hope it works.

Thanks

I have the same problem. I’ll try to follow the instructions mentioned before. grrr!!

How to solve the problem:
(for Windows)
Replace file C:<Katalon path>\configuration\resources\chromedriver_win32\chromedriver.exe with the same file from 76.0.3809.68

1 Like

I updated these and still doesnt work with chrome 76, till chrome 75 it was working fine.
Could someone please suggest some solution?

@libra.soumya17 If it is not working with auto-update then you can manually update the chromedriver

You would need to select it according to your OS from this link

https://chromedriver.storage.googleapis.com/index.html?path=76.0.3809.68/

Then extract it and place it in Katalon Folder

\configuration\resources\chromedriver_win32\

@manpreet.mukkar I tried it, still doesnt work. It actually stops at a specific place, but same script works one previous versions like 5.6 and 5.8 with chrome 76.
and doesnt work with 6.1.2 with chrome 76 even after updating chrome driver.

@libra.soumya17

Please update to KS v6.3.0

Thanks

I tried that as well. The problem is my script is getting stopped at a specific point only since i updated to chrome 76 and till that step my script works fine on same browser.

we are using this godaddy workspace for our application emails and all, and we search email and then fetch something from there. The problem is, now it is not able to put any input in the search inbox textfield, may be you can check the element and see if there is something which is not supported anymore. Because exactly same steps are working on Katalon v 5.6 and 5.8, so I dont think there is any issue with the script. May be something which is not supported now.

I have updated my chrome driver for chrome 76 and tried it with katalon versions 6.1.2, 6.1.3 and 6.3.0 and it is not working.

Let me know if you need more information on this.

Soumya

I swiched to chrome 75 and same script works again with Katalon version 6.1.2.
May be it is something with chrome 76, that the scripts stops at that place.

@duyluong Could you please look into the issue? or may be check what impact chrome 76 has on this Katalon version.

Hi @libra.soumya17,

Please show us the execution logs.

Did the script fail at open browser keyword or at the keyword using the input element?

Thanks

I am facing the same issues where getting msg xpath or attributes is not found.
Previously scripts working fine with the google chrome 75 version but started getting error after upgrade from 75 to 76.0.3809.100 . seeking help on this.

Hello , @ssoni10
With version 6.2.2 of Katalon Studio, I would like to talk about how to fix the Chrome Driver error encountered during the record and run of tests on the ticket.

Operating System Windows 10
Chrome Driver version 76.0.3809.100
Katalon Studio version 6.2.2
While running your tests or recording new tests, you may see an error in the screenshot below.

Consele Logs “This version of ChromeDriver only supports Chrome version 74 (Driver info: chromedriver = 74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs / branch heads / 3729 @ {# 29}), platform = Windows NT 10.0.18362 x86_64” message content is located.

  1. The first way to fix this error: Window> Katalon Studio Preferences> WebUI, and the Automatically update WebDriver option on the relevant page will be activated so that the chrome driver will automatically update to the appropriate version.

  1. The second solution is that the update process that Catalon Studio tries to do automatically in solution 1 is done manually. You should download the appropriate Chrome Driver for Katalon Studio 6.2.2 at https://chromedriver.storage.googleapis.com/index.html?path=76.0.3809.68/

Then, the chromedriver.exe file in the Katalon Studio file, which is located in the file path Katalon_Studio_Windows_646.2.2 \ configuration \ resources \ drivers \ chromedriver_win32, is deleted and the file downloaded from the above extension is added here.

1 Like

hello. I tried it and it didnt work. mine is a Windows 8.1 Pro.
It still cant open the browser.

Hello @benjamin.emina
Could you share the error logs with us? Maybe it is not a problem caused by the driver.

Test Cases/ConceptG/CG-TC01 FAILED.
Reason:
com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ‘www.conceptgroup-ng.com/
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:60)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$openBrowser.call(Unknown Source)
at CG-TC01.run(CG-TC01:16)
at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:337)
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:328)
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:307)
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:299)
at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:233)
at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:114)
at com.kms.katalon.core.main.TestCaseMain.runTestCase(TestCaseMain.java:105)
at com.kms.katalon.core.main.TestCaseMain$runTestCase$0.call(Unknown Source)
at TempTestCase1566211885274.run(TempTestCase1566211885274.groovy:21)
Caused by: org.openqa.selenium.WebDriverException: unknown error: cannot create temp dir for user data dir
(Driver info: chromedriver=74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs/branch-heads/3729@{#29}),platform=Windows NT 6.3.9600 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 606 milliseconds
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’
System info: host: ‘Benjamin-Emina’, ip: ‘192.168.2.105’, os.name: ‘Windows 8.1’, os.arch: ‘amd64’, os.version: ‘6.3’, java.version: ‘1.8.0_181’
Driver info: driver.version: CChromeDriver
at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:214)
at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:166)
at org.openqa.selenium.remote.JsonWireProtocolResponse.lambda$errorHandler$0(JsonWireProtocolResponse.java:54)
at org.openqa.selenium.remote.HandshakeResponse.lambda$getResponseFunction$0(HandshakeResponse.java:30)
at org.openqa.selenium.remote.ProtocolHandshake.lambda$createSession$0(ProtocolHandshake.java:126)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:128)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:74)
at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:136)
at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
at com.kms.katalon.selenium.driver.CChromeDriver.execute(CChromeDriver.java:20)
at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:213)
at org.openqa.selenium.remote.RemoteWebDriver.(RemoteWebDriver.java:131)
at org.openqa.selenium.chrome.ChromeDriver.(ChromeDriver.java:181)
at org.openqa.selenium.chrome.ChromeDriver.(ChromeDriver.java:147)
at com.kms.katalon.selenium.driver.CChromeDriver.(CChromeDriver.java:13)
at com.kms.katalon.core.webui.driver.DriverFactory.createNewChromeDriver(DriverFactory.java:284)
at com.kms.katalon.core.webui.driver.DriverFactory.startNewBrowser(DriverFactory.java:246)
at com.kms.katalon.core.webui.driver.DriverFactory.openWebDriver(DriverFactory.java:191)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.doCall(OpenBrowserKeyword.groovy:74)
at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword$_openBrowser_closure1.call(OpenBrowserKeyword.groovy)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:20)
… 17 more

Hello Again @benjamin.emina
You got the
"Caused by: org.openqa.selenium.WebDriverException: unknown error: cannot create temp dir for user data dir (Driver info: chromedriver=74.0.3729.6 (255758eccf3d244491b8a1317aa76e1ce10d57e9-refs/branch-heads/3729@{#29}),platform=Windows NT 6.3.9600 x86_64) (WARNING: The server did not provide any stacktrace information) " error message.

Please check for Chrome driver updates.

then check if the following option is selected.

1 Like

that is what i am using.
Version 76.0.3809.100 (Official Build) (64-bit)
i have also done the “Automatically update WebDriver”

@emine Thanks for your response but my issue is not related to record and play.

I am facing the issues where xpath is not locating the element.
Previously xpath working fine with the google chrome 75 version but started getting error after upgrade from 75 to 76.0.3809.100 . seeking help on this.
This is the error I am facing:

SLF4J: The requested version 1.7.16 by your slf4j binding is not compatible with [1.6]
SLF4J: See http://www.slf4j.org/codes.html#version_mismatch for further details.
Starting ChromeDriver 76.0.3809.68 (420c9498db8ce8fcd190a954d51297672c1515d5-refs/branch-heads/3809@{#864}) on port 46335
Only local connections are allowed.
Please protect ports used by ChromeDriver and related test frameworks to prevent access by malicious code.
Aug 19, 2019 12:43:26 PM org.openqa.selenium.remote.ProtocolHandshake createSession
INFO: Detected dialect: W3C

Configuration used:-platform 0/S = Windows 7
seleniumVersion = 3.141.59
Browser = Chrome 76.0.3809.100
ChromeDriver 76.0.3809.68
Katalon Studio:- 6.2.2