BUG: GET method gives 404 with Number value | Webservice

  • Katalon Studio Version: 7.5.5
  • OS Version:
  • Browser Version: NA

Steps to Reproduce:
A:

  1. used the Get method to fetch details for company
  2. Used Auth Bearer token (updated)
  3. give all the details required path
  4. Submit Get Request (from object Repository)
    B:
  5. Update The old token value with token and submit the Get request, Not showing Token Expired error (401)

Expected behavior:
For A: It should show the details of company
For B: It should show 401 (unauthorized)

Screenshots:
For Expired token and with refreshed token (same error)

tried used datafiles too


With Globalvariables (after saving updated default profile as number)
image

I can share you the demo on zoom too for this issue.

after submitting the request, on the top-right there is and ‘Har’ link, click on it and you will see the details.
Can you share the content of it, if there is no sensitive data?
If not, check what was the actual url and if the headers are correctly set, from the response looks like the endpoint is not found.

the one with 'findTestData i think it is expected to fail, you cannot use it like that, have to do it in a test case, but the one with GlobalVariable in use should work
Also, make sure that the CompanyID is right (do the same request from Postman).
Parametrized endpoints are also trowing 404 if the in-path variable is wrong … therefore i always suggested developers to avoid them (a better approach will be to use required parameters so the errors can be better controlled)

Hi @bionel

  1. its Working in Postman
    image
    404 in postman to verify:
    image

404 in katalon

  1. HAR file: Pls check your inbox,

  2. Let me if you found anything and all url’s/headers/values are checked no difference found.

Getting ntCoent-Length: 68 like this in katalon with 404 error. is there have to do something in katalon settings ?

Thanks

that’s strange … unless by mistake you somehow edited the har (should be Content-Length).
i think it’s time to call some devs.
@ThanhTo @devalex88 can somebody look into it? looks like a bug. i think were few previous topics, when the endpoint has numbers into it, will somehow convert it into string, sending invalid request. could be the case. (cannot find them right now)

@gsp please send the har file also to one of the devs when they reply, I am not part of the Katalon staff.

@bionel Thanks pls check ur inbox, HAR file is shared already

@gsp yeah, i saw it … but let’s wait for some devs

Hi Any update Bionel

Hi @gsp,
As @bionel has mentioned, please share with us your HAR file.

I did share sir, in your inbox and bionel inbox too.

@gsp you shared with me, confirmed.
Kindly reshare with @huynguyen at least

As i said before, i am not part of katalon staff, just a humble comunity member.
Now you have the eyes of a good katalon team member, use it wisely

2 Likes

shared with huynguyen too :slight_smile: thanks

1 Like