batch execution does not work due to activation failure

I’m trying to execute a batch-command that looks like:

katalon -noSplash -runMode=console -consoleLog -noExit -projectPath=“N:\Katalon\Tests\Arbeitgeberportal\Arbeitgeberportal.prj” -retry=0 -testSuitePath=“Test Suites/Positivtests” -executionProfile=“default” -browserType=“Chrome”.

Everytime i’m starting kalalon manually i have to “activate” it by signing in and it works just fine over there. However the batch-command always throws the follwing error:

Activating…
KA: Unexpected response code from KA server when sending request to URL: https://analytics.katalon.com/oauth/token. Actual: 400, Expected: 200
Failed to activate. Please activate Katalon to continue using.
com.kms.katalon.execution.exception.ActivationException: Failed to activate
at com.kms.katalon.execution.console.ConsoleMain.launch(ConsoleMain.java:156)
at com.kms.katalon.console.application.Application.runConsole(Application.java:71)
at com.kms.katalon.core.application.Application.runConsole(Application.java:96)
at com.kms.katalon.core.application.Application.start(Application.java:79)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

I also tried to add the -email and -password parameters to the batchfile but i received the same error-message. What am i missing?

Thanks in advance
Oliver

could be a conectivity issue … or a bug.
afaik, there are plenty recent issues regarding the analytics domain (and connected features)
hope the root cause will be find out and solved soon.

Till the time issue get’s resolved mention by Ibus, Try this

Use same katalon.exe you have activated manually and use it in Batch then you do not need to activate it.

That’s what i’m doing. The batchfile is in the same folder as the activated katalon.exe. For some reason it still tries to activate again.

that’s strange. could be an issue with your user permisions?
usualy i have to activate katalon only once when installing a new version, after that is keep working without bothering me.
check if an .katalon (hidden) folder is created in C:\Users\yourUserName, i think that is the location where is storing the activation file

Thanks for the fast answer. The manual activation is not required anylonger. That folder you mentioned also exists. Only the batch execution asks me to activate it with the message above.