Basic Report

Please try removing the square brackets [] around the API key.

I removed [ ], used also ’ ’ or just a key, still the same.:cry:
edited :clap: :
OK resolved issue, Proxy was not set in UI.
command line did not accepted proxy parameters passed in section:
–config -proxy.option=MANUAL_CONFIG -proxy.server.type=HTTP -proxy.server.address=“set proxy” -proxy.server.port=8080
I had to start UI run the katalon and put the proxy in via Shift+Ctrl+P proxy.

I there any way to get more detailed logs? like --debug

I wrote above I was able to run it, but when I call it from jenkins error is here again :frowning:

Please add “-consoleLog” in your arguments.


I can not it is not supported on linux as written in docs, but I will try.

it is not supported …
!MESSAGE Exception while dispatching event org.osgi.service.event.Event [topic=PROJECT/OPENED] {} to handler

still no progress :worried:

excuted below shell command on Jenkins in ubuntu, but no basic repor were be generated.

cd /home/jenkins/workspace/project/Development/katalon-testcase/ciAutoTest -browserType=“Chrome” -retry=0 -statusDelay=15 -reportFileName=“report” -testSuitePath=“Test Suites/TS_SmokeTest/TS_HappyFlow” -apikey=[00f0486e-cf14-4def-bcf5-23668e80000]

In the document, says

Open the command prompt and navigate to the folder of your Katalon Studio build, which contains katalon.exe (Windows) or Applications folder (Mac OS) or katalon (Linux) file.

You are doing differently.

Hi, I have upgraded from 5.8.3 to 6.1.5, i.e. I lost native support of test reports, but I am not able to install plug-in Basic Report. I can go to Plugin Store, switch to Basic Report plugin page, click on INSTALL button and nothing happens. Am I doing something wrong? Are there some preconditions? I tried without and also with login, no action. I did not use plugins till now. I tried also generate APIkey and the same result. Any idea?

After update to 6.2.0 I am getting this:

Thu Jun 13 13:00:51 CEST 2019
Failed to reload plugins.
com.kms.katalon.plugin.models.ReloadPluginsException: Unexpected error occurs during executing reload plugins under account: username: No username in this Exception, endpoint:

How to pass in account, username ???

Update: problem was API-key enclosed in […], after removing [ ] it works

I am also facing this problem. I have added the apiKey in the command line along with the proxy information. Still it is not reloading the plugins while executing through command line.

Hello, I have the same problem! Iam pleased for your help!

I am passing proxy to jenkins in scripted pipeline this way:

withEnv(['HTTP_PROXY=http://your-proxy:8080']) {
sh label: 'katalon', script: '''
katalon.... -apiKey=aaa-ppp-iiii

and I have also opened katalon GUI on that jenkins node and set the manual proxy over the katalon UI.
So one of these steps works, I have no time to investigate which one.
It started to work with version 6.2.0 for me. I believe there was a problem with passing proxy in previous.

Can we generate html report from CMD?

It is done automatically, when you use this plugin, you can find it in Reports folder.

Hi Tari,

I tried the below command to run a test suite and generate html report but it’s not working. Can you help me take a look?

C:<mypath>\Katalon_Studio_Windows_64-6.2.0>katalon -noSplash -runMode=console -projectPath=“C:<projectpath><projectname>.prj” -retry=0 -testSuitePath=“Test Suites/” -executionProfile=“default” -browserType=“Chrome” -reportFolder=".\Reports<TestSuiteReportFolder>\test" -reportFileName=".\Reports<TestSuiteReportFolder>\test\report.html"

try to read this …

Perfect, it’s working. Thank you!

My account is not having install button on plugin report. So I could not install plugin on the latest version of Katalon

. Any idea to fix it ? (I already generated api key)

I run the test in docker. It takes more than 20 minutes to install the plugins everytime.
Is there any optimization way?

This is my command:

docker run -t --rm -v "$(pwd)":/katalon/katalon/source katalonstudio/katalon -retry=1 -retryFailedTestCases=true -testSuiteCollectionPath="Test Suites/tc_"$env -apiKey=XXXXX