Allow my location in headless

Morning everyone.
For the past few days, I have been dealing with an issue when running a specific web test in headless mode.
The test involves booking an appointment and I want to be able to use the my location option.
The test runs fine in regular chrom testing, but when I try to use the same test in headless, The execution shows the my location as being clicked, but the address options do not show for the next test step.

I believe that there must be some king of issues with the headless test allowing it’s location to be used.

I was wondering if anyone else has had this problem before?
Is there some way to allow the location to be used for headless tests?

Thanks in advance!

@Mate_Mrse?

I believe this is the nature of Chrome Headless. Infact most of your chrome settings do not carry over in to chrome headless and things like window size etc need to be configured. You might be able to utilize this:

Hi, any solution?

Hi,
Since Katalon became pay to use, we have decided to go for an open source solution for automation.
If I come across this issue and find a way to resolve, I will try to remember to update here though.