All Katalon Studio Saving Issues (was Unable to save part)

I’m moving this to the Bugs forum (missed that yesterday).

Calling out to @devalex88 @YoungNgo @duyluong @ThanhTo for some movement on this.

1 Like

We will try to resolve this issue in April.


Thank you sir! :grinning:


@tomoya_chen @Morgan Could you please check if 6.1.2 fix your issues?

Appears to fix it for me! Thank you!

1 Like

Maybe my environment is special. I still encounter this problem in v6.1.2 Build 2.
My PC is Win7 x64, IE 8

log.txt (7.6 KB)

Alex, April is rapidly drawing to a close. Frankly, I don’t see any signs that saving issues will be solved any time soon.


Katalon is first and foremost an IDE. It should save, successfully every time.

Here’s my UX:

  1. Editing a large-ish keyword class.
  2. I notice formatting/assist issues.
  3. I save. Now one of two things happens:
    3.1 The asterisk in the tab is not removed
    3.2 The asterisk is removed but further changes do not cause the asterisk to reappear.
    Whichever of these happens, I know Katalon is screwed at this point, so…
  4. Copy the entire tab content to notepad.
  5. Close the class file in Katalon.
  6. Reopen it
  7. Paste the content from notepad over the content in Katalon.
  8. Save works again.

14 months I’ve been doing this.

Please, take it to the top and let’s get this fixed, before 6.2.n


I use the Katalon version 6.1.4-43458715e and i have the same problem :frowning:
When i work in the same file and i need to save/copy/paste several time, this problem happens.

Please fix that ASAP.
Thank you.


I use the Katalon version 6.1.5 and 6.1.2 suffer to save error that is unable save the part.
I tried to update laste version,but it is not ok.
Please give me some suggestions.

@Alice @Loan_Tran Please try reproducing this issue.

@everyone since there might be different scenarios that cause the issue it would be a great help if you provide detailed descriptions.

Since this was bumped by the system… and it’s now another year later…

@Loan_Tran @ThanhTo @duyluong Any news? Progress?

@devalex88 Any chance KS 8.0 (with the new eclipse stuff) will make this go away?

We have spent a lot of effort on reproducing the issue but we have no luck.
@tomoya_chen @Morgan Have you still seen the issue with the latest release? If yes, can you share us your script and provide us the exact steps you did to meet the issue?

I’ve given you the steps a number of times. Here’s one from TWO years ago - please read the whole thread. Bug in Katalon Studio Save Routine - #3 by Russ_Thomas

The script is not the issue - it can be small, or large.

The issue seems to appear when there are many files open and two or three or even four or five need saving. Then, when one is saved, or ALL are saved via Save All, one of them does NOT save. From that moment on, saving is not possible, changes are not saved. Editing in the culprit file does not make the * appear (it’s not there because the system “thinks” it has been saved). The only cure then is to copy the changes to Notepad, close the file (the system does NOT ask to save changes - again because it thinks it is saved) and reopen it. THEN the * appears in the tab.

Here is what I mean by “many files open”:

Hi @Russ_Thomas,
I believe the script containing something special so that it is unable to save it. I tried opening many files but still saving successfully. Can you share us your script?