Admin Rights?


#1

Do you need admin rights on the PC to execute a Test?


#2

no, you dont need to be admin to execute test (unless you want to execute on IE)


#3

https://drive.google.com/file/d/1jXAzmfaHsJmq9fXgJYb45KYjfeNOd1yY/view

Weird because i have tried 2 different laptops and have the same problem running a test.


#4

on my PC i don’t even have admin rights - i’m not able to install anything and yet, i’m running tests (even now)
btw. if you have something to show, put it directly here… i don’t have access to gDrive


#5

error2.PNG

error.PNG


#6

is this test working somewhere else? - answered above -
can you post source of your script? seems it’s something wrong with that code


#7

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint

import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase

import static com.kms.katalon.core.testdata.TestDataFactory.findTestData

import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject

import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint

import com.kms.katalon.core.checkpoint.CheckpointFactory as CheckpointFactory

import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as MobileBuiltInKeywords

import com.kms.katalon.core.model.FailureHandling as FailureHandling

import com.kms.katalon.core.testcase.TestCase as TestCase

import com.kms.katalon.core.testcase.TestCaseFactory as TestCaseFactory

import com.kms.katalon.core.testdata.TestData as TestData

import com.kms.katalon.core.testdata.TestDataFactory as TestDataFactory

import com.kms.katalon.core.testobject.ObjectRepository as ObjectRepository

import com.kms.katalon.core.testobject.TestObject as TestObject

import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WSBuiltInKeywords

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUiBuiltInKeywords

import internal.GlobalVariable as GlobalVariable

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI

import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as Mobile

import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS

WebUI.comment(‘Story: Book an appointment’)

WebUI.comment(‘Given that the user has logged into their account’)

WebUI.openBrowser(GlobalVariable.G_SiteURL)

WebUI.callTestCase(findTestCase(‘Common Test Cases/Login’), [‘Username’ : ‘John Doe’, ‘Password’ : ‘ThisIsNotAPassword’],

FailureHandling.STOP\_ON\_FAILURE)

WebUI.comment(‘And Appointment page is displayed’)

if (true) {

WebUI.selectOptionByLabel(findTestObject('Page\_CuraAppointment/lst\_Facility'), 'Hongkong CURA Healthcare Center', false)



WebUI.check(findTestObject('Page\_CuraAppointment/chk\_Medicaid'))



WebUI.check(findTestObject('Page\_CuraAppointment/chk\_Readmission'))



WebUI.setText(findTestObject('Page\_CuraAppointment/txt\_VisitDate'), '27/12/2016')



WebUI.setText(findTestObject('Page\_CuraAppointment/txt\_Comment'), 'Please make appointment as soon as possible.')

}

WebUI.comment(‘When he fills in valid information in Appointment page’)

WebUI.click(findTestObject(‘Page_CuraAppointment/btn_BookAppointment’))

WebUI.verifyTextPresent(‘Appointment Confirmation’, false)

WebUI.comment(‘Then he should be able to book a new appointment’)

if (true) {

WebUI.verifyMatch(‘Hongkong CURA Healthcare Center’, WebUI.getText(findTestObject(‘Page_AppointmentConfirmation/lbl_Facility’)), false)

WebUI.verifyMatch(‘Yes’, WebUI.getText(findTestObject(‘Page_AppointmentConfirmation/lbl_HospitalReadmission’)), false)

WebUI.verifyMatch(‘Medicaid’, WebUI.getText(findTestObject(‘Page_AppointmentConfirmation/lbl_Program’)), false)

WebUI.verifyMatch(‘27/12/2016’, WebUI.getText(findTestObject(‘Page_AppointmentConfirmation/lbl_VisitDate’)), false)

WebUI.verifyMatch(‘Please make appointment as soon as possible.’, WebUI.getText(findTestObject(‘Page_AppointmentConfirmation/lbl_Comment’)), false)

}

WebUI.closeBrowser()


#8

ok, i think it will be no help to you telling that it executes on my PC … so some questions that comes to my mind:
1. did you try create your own project and test case - open browser with google.com, close browser and run it?
2. how did you install Katalon - where?
3. how are set access rights on project folder?
4. is Katalon/project stored on network drive?
if you can, please be verbose


#9

Thanks for your effort. To Answer your questions
1. I tried creating my own project and i was not able to record.
2. I just click on the .exe file in the katalon folder
2. The folders do not have any restrictions
3. The folder is on a network drive. and i have full access and permissions to the network.


#10

issue solved. its because the Katalon Folder was on the network drive.


#11

good to hear