Adding a New Formatter Causes Recoder to Fail

Hello Katalon Team,

I’m having an issue where any change made to any of the recorder files causes the recorder to display incorrectly (see image below) and Chrome then flags the extension as corrupt.1

First test: I changed the sample.js file name to test.js in panel\js\katalon\newformatters; opened test.js and changed newFormatters.sample to newFormatters.test; and then updated every occurrence of ‘sample’ to ‘test’ within index.html. I made no other changes. The plugin fails. When I revert all changes, the plugin goes back to working just fine.

Second test: I opened panel\js\katalon\newformatters\nrsynthetics.js and added an ‘r’ to the end of the very first commented line. That’s it. A single ‘r’ inside a comment. I made no other changes. I saved the file, tried to open the plugin, and it was immediately flagged as corrupt and closed. I removed the r, saved the file, and the plugin opens with no issues.

Third test: I opened index.html and simply added a single space to a commented line. Plugin fails.

I’ve tried this on my local machine and an unrelated cloud server. Same exact issue. What am I missing/doing wrong?


1 Like

i’m extremely disappointed in the lack of response from the katalon team.

1 Like

Sorry for the late response. I’ve tried this step and KR worked fine. If you are still interested, please give me a sample Pull Request so I can look through all the changes.