Unable to record/Spy few mobile apps??

Question

I’m not able to record or spy few mobile apps (eg:Amazon ), it will launch the app for few seconds and close but it will not load the screen?

Thanks in advance.

Abhi

in progress 0
How to 12 Answer 244 views

About the Author

Answers ( 12 )

  1. Please set your Appium Log Level to “Debug” (You can find this option in Windows > Katalon Studio Preferences > Katalon > Mobile), then retry Mobile Object Spy and send me the appium.log file again for further investigation which located in your project folder (https://i.imgur.com/IyxzrCI.png).

  2. Please find the log file.

    I’m able to launch other apps successfully and record it ,facing issues with only few apps.

     

    https://view.stoamigo.com/item/3c9d1a6f59bdcc04

  3. Please try the following steps:

    1. Navigate to Mobile settings: Project -> Settings -> Execution -> Default -> Mobile -> Android
    2. . Add ‘appWaitActivity’ key and value: ‘com.mint.core.overview.PhoneOverviewActivity’

    After above configurations, please try to record/spy again.

  4. Cool.It’s working now.

     

    Thank you.

  5. This comment is edited.

    Sorry,it worked only for the first time.After that none of the app is getting recorded/spy.

    Please find the below log file.

    https://view.stoamigo.com/item/d6e7185e74cd9c06

     

  6. That settings is only applied for that specific application only. When you record or spy on another application, it will not work. Is it the same application when you run or record/spy?

  7. This comment is edited.

    Even for same app Rec/Spy is not working.It worked only for the first time.When i tried to record again it will launch the app and close immediately.

    And also not able to launch directly from script.

     

  8. Is your newest .appium logs has been configured using ‘Debug’ level as I’ve stated from the beginning?

  9. This comment is edited.

    Omg based on that logs, looks like the previous settings value you’ve set has been changed from within the application, so in order for Katalon Studio to works now, you need to change ‘appWaitActivity‘ key to ‘*‘ value to prevent other changes from application later.

    Here is the log from your first one:

    Found package: 'com.quicken.qm2014' and fully qualified activity name : 'com.mint.core.overview.PhoneOverviewActivity'

    Your newest one:

    Found package: 'com.quicken.qm2014' and fully qualified activity name : 'com.mint.core.overview.PhoneOverviewActivity'

Leave an answer