IE11 recording testcases doesnt work past 3 first steps

Question

Hello!

 

New here & currently considering switch from Selenium to Katalon, since IE11 support is required for our case.

I installed and followed the IE configuration guide, but I still ran into problem trying to record test steps with IE11.

The web app I am testing has a login page initially. Katalon records username/password and \”submit\” button tasks, but beyond that, nothing happens anymore. No click on navigation, double click or any other action is recorded beyond the login.

Can you provide any assistance on this?

in progress 1
Execution 2 Answer 67 views

About the Author

Answers ( 2 )

  1. Hi timo,

    Could you specify your test case and provide us the screenshot of the recorded test case from Katalon Studio?

    Thanks.

  2. Hello! Unfortunately providing a screenshot, which in normal case would be handy, is not possible due to the nature of the work.

    However, there is no chance, message or any changing behaviour in Katalon Studio, the recording simply stops logging steps. Record button is still on and nothing is visually happening in the studio.

    The test case is as follows:

    (After installing Katalon Studio, installing IE plugin, configuring IE11 settings (zones, ench. protection, regedit, zoom), after creating Project & test case as on the instuction videoss)

    I start recording from Record Web. I choose IE as the default and set up starting URL.

    Starting url is a simple java login page. User/password and submit, which are all recorded by Katalon.

    After submit, i arrive on the actual landing page and this is where the recording, everytime, stops. No record of arriving to the page, submit button click is always the last action. No further steps are recorded, no matter what I click, IE still has the red bounding boxes and recording is in “running” state on Katalon.

    No logs are saved by Katalon to AppData about this (only logs were from previously before I installed the IE plugin), besides them, the log folder is empty.

    Lastly, its a private network without any access outside, but i suppose that shouldnt have any effect on the problem.

Leave an answer