Katalon Studio v5.8 - It's time for the all-new API testing experience
abhinandan
Katalon Apprentice
06/19/2017

Unable to record/Spy few mobile apps??

I'm not able to record or spy few mobile apps (eg:Amazon ), it will launch the app for few seconds and close but it will not load the screen?

Thanks in advance.

Abhi

Upvote
Quote

Comments

  • Hanh Tran
    Katalon Ambassador
    06/19/2017
    Please set your Appium Log Level to "Debug" (You can find this option in Windows > Katalon Studio Preferences > Katalon > Mobile), then retry Mobile Object Spy and send me the appium.log file again for further investigation which located in your project folder (https://i.imgur.com/IyxzrCI.png).
    Upvote
    Quote
  • abhinandan
    Katalon Apprentice
    06/19/2017
    Please find the log file.

    I'm able to launch other apps successfully and record it ,facing issues with only few apps.

     

    https://view.stoamigo.com/item/3c9d1a6f59bdcc04
    Upvote
    Quote
  • Hanh Tran
    Katalon Ambassador
    06/19/2017

    Please try the following steps:

    1. Navigate to Mobile settings: Project -> Settings -> Execution -> Default -> Mobile -> Android
    2. . Add 'appWaitActivity' key and value: 'com.mint.core.overview.PhoneOverviewActivity'

    After above configurations, please try to record/spy again.

    Upvote
    Quote
  • abhinandan
    Katalon Apprentice
    06/20/2017
    Cool.It's working now.

     

    Thank you.
    Upvote
    Quote
  • abhinandan
    Katalon Apprentice
    06/20/2017
    Sorry,it worked only for the first time.After that none of the app is getting recorded/spy.

    Please find the below log file.

    https://view.stoamigo.com/item/d6e7185e74cd9c06

     
    Upvote
    Quote
  • abhinandan
    Katalon Apprentice
    06/20/2017
    Below is the console error,when i try to run app directly.

     

    https://view.stoamigo.com/item/819b1ae31915d802
    Upvote
    Quote
  • Hanh Tran
    Katalon Ambassador
    06/20/2017
    That settings is only applied for that specific application only. When you record or spy on another application, it will not work. Is it the same application when you run or record/spy?
    Upvote
    Quote
  • abhinandan
    Katalon Apprentice
    06/20/2017
    Even for same app Rec/Spy is not working.It worked only for the first time.When i tried to record again it will launch the app and close immediately.

    And also not able to launch directly from script.

     
    Upvote
    Quote
  • Hanh Tran
    Katalon Ambassador
    06/20/2017
    Is your newest .appium logs has been configured using 'Debug' level as I've stated from the beginning?
    Upvote
    Quote
  • abhinandan
    Katalon Apprentice
    06/20/2017
    Please find the new log file.

     

    https://view.stoamigo.com/item/e237bfdb5a1ddc0c
    Upvote
    Quote
  • Vinh Nguyen
    Katalon Moderator
    06/20/2017
    Omg based on that logs, looks like the previous settings value you've set has been changed from within the application, so in order for Katalon Studio to works now, you need to change 'appWaitActivity' key to '*' value to prevent other changes from application later.

    Here is the log from your first one:

    Found package: 'com.quicken.qm2014' and fully qualified activity name : 'com.mint.core.overview.PhoneOverviewActivity'

    Your newest one:

    Found package: 'com.quicken.qm2014' and fully qualified activity name : 'com.mint.core.overview.PhoneOverviewActivity'
    Upvote
    Quote
  • abhinandan
    Katalon Apprentice
    06/22/2017
    It worked:-)

     

    Thank you.
    Upvote
    Quote
  • Sandeep Kommineni
    Katalon Apprentice
    10/13/2017

    it worked Unable to record/Spy few mobile Appium app

    Upvote
    Quote
  • Isable Jason
    Katalon Apprentice
    08/11/2018
    Yes, it worked for me also but the appium app is unable to Spy & record during the process.
    Upvote
    Quote
  • chand mehta
    Katalon Apprentice
    08/13/2018

    Unable to capture objects in android emulator but same is working fine in real device

    I want to automate a hybrid mobile App built in Cordova using emulators. I am not able to capture elements on an emulator. While capturing the elements, the element retrieved is not found when the script is executed. Along, the elements on a HTML panel object are never captured. I made the script on the real device with same specification as my emulator and it worked like a charm there. But the emulator always behaves unexpected.

    Any help will be highly appreciated. I am really stuck in this issue.

    Upvote
    Quote
Sign In or Register to comment.