Alejandro
Katalon Apprentice
07/10/2017

did not provide any stacktrace

I have a problem to deploy the katalon Software in native app (mobile vs Samsung A5 vs 05.00.02) .

When I try to run a mobile spy Object , in a real device , the katalon shows me this fault "Unable to start aplication on this device. An uknown server-side error occurred while processing the command.Error Occurred while starting App...".

With example code (APIDemos) works correctly.

The question is ... Is it necessary deploy some library in the app, for the automate will be available ?

or Is it the installation fault in MAC PC?

It's necessary implement some method in the source code?

Thanks in advance.

Regards

 

 

Upvote
Quote

Comments

  • Alaqua Fina
    Katalon Apprentice
    07/11/2017
    No you don't need it. It is the problem of Appium itself. Can you set your Appium Log Level to "Debug" (You can find this option in Windows > Katalon Studio Preferences > Katalon > Mobile) , retry your execution and send me appium.log file which is available in your project folder?
    Upvote
    Quote
  • Alejandro
    Katalon Apprentice
    07/11/2017
    [debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS_CODE: 0
    [debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS: stream=
    [debug] [AndroidBootstrap] [UIAUTO STDOUT] Test results for WatcherResultPrinter=.
    [debug] [AndroidBootstrap] [UIAUTO STDOUT] Time: 26.707
    [debug] [AndroidBootstrap] [UIAUTO STDOUT] OK (1 test)
    [debug] [AndroidBootstrap] [UIAUTO STDOUT] INSTRUMENTATION_STATUS_CODE: -1
    [debug] [UiAutomator] UiAutomator shut down normally
    [debug] [UiAutomator] Moving to state 'stopped'
    [debug] [ADB] Attempting to kill all uiautomator processes
    [debug] [ADB] Getting all processes with uiautomator
    [debug] [ADB] Getting connected devices...
    [debug] [ADB] 1 device(s) connected
    [debug] [ADB] Running '/Applications/Katalon Studio.app/Contents/Eclipse/configuration/resources/tools/android_sdk/platform-tools/adb' with args: ["-P",5037,"-s","7bf351a9","shell","ps"]
    [ADB] No uiautomator process found to kill, continuing...
    [debug] [UiAutomator] Moving to state 'stopped'
    [debug] [Logcat] Stopping logcat capture
    [debug] [ADB] Getting connected devices...
    [debug] [ADB] 1 device(s) connected
    [debug] [ADB] Running '/Applications/Katalon Studio.app/Contents/Eclipse/configuration/resources/tools/android_sdk/platform-tools/adb' with args: ["-P",5037,"-s","7bf351a9","shell","am","force-stop","io.appium.unlock"]
    [debug] [AndroidDriver] Not cleaning generated files. Add `clearSystemFiles` capability if wanted.
    [HTTP] <-- POST /wd/hub/session 500 43156 ms - 376
    Upvote
    Quote
  • Vinh Nguyen
    Katalon Moderator
    07/11/2017
    Is that the FULL logs? Which Appium version and Android version from your device?
    Upvote
    Quote
  • Vinh Nguyen
    Katalon Moderator
    07/11/2017
    I see, these lines say it all:

    [debug] [ADB] Found package: ‘com.seat.connectedcar.csharing.localMock’ and fully qualified activity name : ‘com.seat.connectedcar.csharing.presentation.home.MainActivity’
    [debug] [ADB] Incorrect package and activity. Retrying.
    [debug] [ADB] Getting focused package and activity
    [debug] [ADB] Getting connected devices…

    In order to resolve this one,please try adding the following key Mobile settings (Project > Settings > Execution > Default > Mobile > Android)
    - Name: appWaitActivity
    - Value: com.*

    Thanks
    Upvote
    Quote
  • Alejandro
    Katalon Apprentice
    07/11/2017
    OOOOOooo many thanks. The issue is solved.

     
    Upvote
    Quote
  • Alejandro
    Katalon Apprentice
    07/12/2017
    Other question , if I would like configure to test the same App in IOS, ¿Is it necessary configure the same property, or I need other name and another value ?
    Upvote
    Quote
  • Hanh Tran
    Katalon Ambassador
    07/12/2017
    You don't need to define this settings on iOS application as I believe this issue doesn't happen on iOS application
    Upvote
    Quote
  • Eric Dannenbaum
    Katalon Apprentice
    10/09/2017

    Can you follow up on this? I am experiencing similar issues

    Upvote
    Quote
  • Girish
    Katalon Apprentice
    03/01/2018
    Vinh Nguyen  can you help me even am getting the same issue i tried your solution but not working 
    log file 
    [debug] [ADB] Running 'C:\Users\Girish\.katalon\tools\android_sdk\platform-tools\adb.exe' with args: ["-P",5037,"-s","18fcda489804","shell","dumpsys","window","windows"]
    [debug] [ADB] Found package: 'BlueOyster.Android' and fully qualified activity name : 'md5b47bf86abca8e5d35fdf338b50c8a136.MainActivity'
    [debug] [ADB] Incorrect package and activity. Retrying.

    Thanks,
    Upvote
    Quote
Sign In or Register to comment.