Vivian Nastasa
Katalon Apprentice
12/13/2017

Real iPhone doesn't show up in local devices list

Hi,

I followed the steps here and tried to test the setup but the last line was not Listening on USB, it ended as following:

Test Suite 'All tests' started at 2017-12-12 15:14:36.698
Test Suite 'WebDriverAgentRunner.xctest' started at 2017-12-12 15:14:36.700
Test Suite 'UITestingUITests' started at 2017-12-12 15:14:36.701
Test Case '-[UITestingUITests testRunner]' started.
    t =     0.00s Start Test at 2017-12-12 15:14:36.702
    t =     0.00s Set Up
2017-12-12 15:14:36.712202+0100 WebDriverAgentRunner-Runner[327:25088] Built at Dec 12 2017 15:02:03
2017-12-12 15:14:36.738767+0100 WebDriverAgentRunner-Runner[327:25088] ServerURLHere->http://someip:0<-ServerURLHere


Guessing this is the reason why my real device doesn't show up in the local devices list, I can only see the Xcode emulators in the drop-down.

Developer mode is enabled and UIAutomation is ON.

iPhone trusts the Mac.

Device Management trusts my dev account and WebDriverAgentRunner-Runner app has status 'Verified'.

Also tried both USB ports on my Mac.


Using:

Appium 1.7.0

iPhone 6S Plus with iOS 11.2

Mac OS High Sierra 10.13.2

Katalon Studio 5.2.0

Latest carthage and node/npm.


Best Regards,

Vivian

Tagged:
Upvote
Quote

Comments

  • Vinh Nguyen
    Katalon Expert
    12/13/2017
    Hi Vivian,

    Can you tell me how long does it hang?
    Upvote
    Quote
  • Vivian Nastasa
    Katalon Apprentice
    12/13/2017
    Sure,

    I had it running again today, just in case and it's been like that for 2 hours now. Exact behaviour as described above.

    Cheers,
    Vivian
    Upvote
    Quote
  • Vinh Nguyen
    Katalon Expert
    12/13/2017
    Is this log: "http://someip:0<-ServerURLHere" a real one from yours? 
    Upvote
    Quote
  • Vivian Nastasa
    Katalon Apprentice
    12/13/2017
    edited December 2017
    Yes, I just replaced the IP as I didn't want to put it on a forum. The port is correct.
    Upvote
    Quote
  • Vivian Nastasa
    Katalon Apprentice
    12/18/2017
    edited December 2017
    Ok,

    Update time:

    I tried a different phone, since I cannot downgrade from iOS 11 anymore on the previous device.
    Got an iPhone 5s running iOS 10.3.1. - went for this version since I noticed this is what the Kobiton devices were running.
    Adjusted webDriver build settings to this iOS version, clean, build.
    Trusted both ways, ran the test with the same outcome, not listening on USB. Last line is again the server url, which is confirmed as the iPhone's ip.
    Katalon picked it up as a local device.

    Since I don't want to update this phone too just to prove a theory, my best guess is that Katalon needs some work on iOS 11.x support and fast, since any iOS version older than 11 is not getting signed by Apple anymore.

    Thanks,
    Vivian
    Upvote
    Quote
  • Sahil
    Katalon Apprentice
    12/19/2017
    Hi

    I am also facing the similar issue on Mac. Issue is that my real devices is not displayed in the device list.

    iOS version : 11.1.2
    X Code version : 9.1
    Appium version : 1.7.1

    On earlier versions it was working fine. Please look into this on the priority basis.
    Upvote
    Quote
  • Vinh Nguyen
    Katalon Expert
    12/19/2017
    Hi Sahil,

    Is your issue the same with Vivian? Or is there any other misconfigurations or error from your setup? 

    When you say on earlier versions, you mean Katalon Studio or your iOS/Xcode/Appium version?

    Regards

    Upvote
    Quote
  • Vinh Nguyen
    Katalon Expert
    12/19/2017
    By the way, I will try again with iOS11 and see if there is anything wrong with it.
    Regards

    Upvote
    Quote
  • Sahil
    Katalon Apprentice
    12/21/2017
    Hi Vinh,

    I am also facing the similar issue on Mac. Issue is that my real devices is not displayed in the device list.

    iOS version : 11 +
    X Code version : 9 +
    Appium version : 1.7.1
    Katalon Version : 5 and above

    When earlier I executed the test cases 20 days back then device is displayed on the list. Below are the tools version I was using:
    iOS version : 10 + but less than 11
    X Code version : 8 + but less than 9
    Appium version : 1.6
    Katalon Version : 4.7, 4.8

    Please look into this on the priority basis.
    Upvote
    Quote
  • Vinh Nguyen
    Katalon Expert
    12/22/2017
    edited December 2017

    Hi Sahil,

    Thanks for your information. Actually, I'm looking at this issue too and likely the root cause of it is not from Katalon Studio, but also relates to iOS and Appium version.

    Regards

    Upvote
    Quote
  • Joanna Niemczyk
    Katalon Apprentice
    12/22/2017

    Have any of you found a fix for this? I recently updated an iPad mini to iOS 11.1.2 and am having troubles with Katalon recognizing the device.

    Upvote
    Quote
  • Vinh Nguyen
    Katalon Expert
    12/23/2017

    Hi Joanna,

    Not yet, we are still investigating on it. Hopefully it will be fixed soon or need some more adjustments in our setup to adapt this, so please wait for it :)

    Upvote
    Quote
  • Vinh Nguyen
    Katalon Expert
    12/26/2017
    Hi all,

    We've investigated and will apply a support for iOS 11 in the next release. Looks like the current mobile core of Katalon Studio does not handle iOS 11 fully, so that's why you can't see iOS 11 devices listed.

    Thanks for your understanding.

    Regards
    Upvote
    Quote
  • Pranshu
    Katalon Apprentice
    01/16/2018
    edited January 16
    Hi Vinh,

    I am facing this same issue using an ipad air 2 with iOS 11+. Can you give us any insights as in which version of Katalon studio are we planning to fix this iOS 11 handling ? 
    Upvote
    Quote
  • Vinh Nguyen
    Katalon Expert
    01/16/2018
    Pranshu said:
    Hi Vinh,

    I am facing this same issue using an ipad air 2 with iOS 11+. Can you give us any insights as in which version of Katalon studio are we planning to fix this iOS 11 handling ? 
    Hi Pranshu,

    The next version of Katalon Studio (5.3) will address this issue. It is planned to deliver in one or two weeks later.
    Upvote
    Quote
  • Giuliano Infantino
    Katalon Apprentice
    02/22/2018
    edited February 22

    Hi Alex,

    Still facing the same problem with :

    * Katalon studio 5.3
    * Appium 1.7.2
    * Real device under iOS 11.2.2 (and even iOS 10.3.*)
    * Xcode 9.2

    My devices are not recognized, it's a major issue for us.
    Can u please have a look ?


    Regards,


    Giuliano



    Upvote
    Quote
  • surendra rachakonda
    Katalon Apprentice
    03/20/2018
    same problem here and in simulator issue with webDriverAgent build  
    Upvote
    Quote
Sign In or Register to comment.